Boron 2G/3G and 3rd-party sim card

Hello
today i will change Sim card to a 3rd party (Swiss Sunrise) but I was not able to do.

First Step :I use the particle identify --> answer is: Could not identify device: No serial port identified
Second step: I put the device in Listening Mode --> I press mode button till flashing
blu led then use particle identify answer was correct
Your device id is xxx
Your IMEI is xx
Your ICCID is xx
Your system firmware version is 0.8.0-rc.26
Third step:
I tray to put the device in DFU mode and use the particle identify this is the answer:
Could not identify device: No serial port identified

No device on control panel
image

I use windows 10, my system recognize core, photon without problems connect to USB port.
Some people can help me to change the sim card?
Thanks a lot
Valentino

Sure thing. In DFU Mode the device doesn’t open a USB Serial port. In DFU Mode the device acts as a DFU device and not as USB Serial device.
When attach your Photon in DFU Mode, where does it show up in Device Manager?
That’s where a Boron would/should show up too. But since your Windows probably doesn’t know which driver to use for Boron in DFU Mode you need to assign the drivers.
Either via zadig or by reinstalling CLI via the most recent Installer.

BTW, particle identify will never identify your device in DFU Mode, since it’s only supposed to work in Listening Mode.

To change the SIM card, you need to flash an application firmware that sets the cellular credentials and activate the external SIM.

Hello ScruffR for the moment thanks I will give a feedback.
At the moment I wish you a Happy New Year.
Valentino

1 Like

Hello ScruffR
like your suggestion I reinstall the CLI and I’m able to setting up my Boron with the 3rd-party sim card.
I fellow the instruction activate the external SIM, only one this step I have problem :

particle compile boron 3rdPartySIM.cpp --saveTo firmware.bin --target 0.8.0-rc.25
particle flash --usb firmware.bin

–target 0.8.0-rc25 was refuse so forget on the command and I finish with the flash

This is the Boron on system
image
Thanks a again for your support
Valentino

If you want to flas via --usb your device needs to be in DFU Mode (blinking yellow) and should show up in Device Manager as libusbK (or equivalent DFU device).

Like here
image