Unable to setup my Boron 2G/3G with 3rd party sim

Unable to setup 3rd party sim with my 2G/3G Boron.

I am following,

https://docs.particle.io/support/particle-devices-faq/electron-3rdparty-sims/#setting-up-a-3rd-party-sim-card-boron

every step as it is but keep getting an assertion error( 10 red blinks after SOS blinking) every time after flashing tinker@1.2.1.bin and have to factory reset my device every time. Tried several times but with the same outcome. I can’t seem to find where I might be going wrong.

An update to the instructions will be coming shortly. It should instead read:

If you’re ready to set up your Boron, follow these steps:

  • You must have the Particle CLI (version 1.47.0 or newer) installed. Use particle update-cli to upgrade if necessary.
  • Put the Boron in DFU mode (blinking yellow) by holding down MODE. Tap RESET and continue to hold down MODE. The status LED will blink magenta (red and blue at the same time), then yellow. Release when it is blinking yellow.
  • Update the device. If the device goes out of blinking yellow after the first command, put it back into DFU mode.
particle update
particle flash --usb tinker
  • When the command reports Flash success!, reset the Boron. It should go back into listening mode (blinking dark blue).

  • Create a program to set the APN and switch to an external SIM. Here’s the code. One way is to save this to a file, I called mine 3rdPartySIM.cpp.

(the rest of the instructions are the same)

2 Likes

Thanks for the help @rickkas7. I followed as you instructed, updated the boron and flashed tinker in dfu mode but it doesn’t go into listening mode after the tinker flash, instead restarts and looking for internet ( fast blinking green) and stays that way. I updated and flashed tinker multiple times but still no listening mode. Should I manually set into listening mode and try setting the APN?

PS: After the update, it has firmware version is 1.4.0