Blink cyan after 10-50 seconds

I have several Photons on the same network. Two are working fine, but when I try to add a new one it connects for a while (breaths cyan) and after 50 seconds or less blinks cyan (2 orange).
I’ve flashed with Tinker and it does the same.
So I tried a different, new out-of-the-package Photon, and it acts the same.
I recently upgraded my network to mesh (wired backbone), and tried moving the Photon around, but no difference.
I would think the network is causing it, since that’s my most recent change, but I can’t explain why the existing Photons work while the new ones don’t, and they’re on the same SSID.

@ronlisle, normally, two orange blinks mean the device can’t reach the internet.

  • Does the device blink red at any time?
  • Which version of deviceOS are the Photon’s running?

Also, are you sure it is two not three orange blinks? With three orange blinks the issue is likely the device keys need updating. You could try using the Particle keys doctor via CLI.

Thanks for the info.
Yes, unfortunately it is 2 blinks.
All photons are running 2.3.0
I’ve run keys doctor.
I’ve run Cloud Debug: sequence starts good, then (summarizing):
* ERROR: Event loop error 1
* Cloud Disconnecting (x2)
* INFO: Lost cloud connection after 00:50 (sometimes as little as 00:10)
* Cloud connecting
* Cloud socket connection failed: -2
* Internet test failed: timeout
* Handling cloud error: 2
This then loops forever.
Also strangely, my console.particle.io reports the device as active (initially).

Hi, are the 2.4GHZ and 5GHz SSIDs different?
thanks

Hello,

Have you run the Device restore tool seen here: Device Restore USB | Tools | Particle? If that still doesn’t do it, can you share your Cloud Debug log and your Device ID with me privately.

Yes, I have separate SSIDs for 2.4GHz and 5GHz.
The Photons are all connected to the 2.4GHz SSID, which also is limited to 20Mhz bandwidth.

Lance, I have messaged you with the Device ID and Cloud Debug logs.

@ronlisle, did any the Photons have static IPs assigned to them in the past?

I normally would suggest that the gateway is blocking the COAP ports to the Particle server but you have two devices connecting. Can you explain a bit more about the recent changes you made to your network?

Yes, I do have static IPs assigned to 3 other Photons, and these are working.

My network setup is installed in my 44’ RV. My wife and I are full-time RVers. The system is setup to run off 12v. I have a RaspberryPi running an MQTT broker. My intent is that everything works locally from battery, with an internet connection being optional. I have several Echo devices which provide voice control when the internet is connected.

I’ve been using a Pepwave Max Transit Duo router with roof mounted antenna for a couple years. It has worked fairly well, but I have occasionally had trouble connecting from the very rear of the RV where my office is. I attribute this to interference from all the other RV’s in the area.

So I decided to add an addition AP (LinkSys E5400) in the office with an ethernet cable run to it. This has definitely fixed my office issue. I initially used a separate SSID for it, but that was a nuisance as I moved with my laptop around the RV.

So the most recent change was to configure the AP for mesh. The Pepwave is the DHCP server, and the LinkSys is in bridged mode. This appears to be working, except for the new Photons that don’t stay connected.

Frankly, I’m way over my head here with all this networking and apologize for any terminology misuse.

I tried restoring my network to how it was before I started having trouble (separate SSIDs instead of mesh/bridged).

One of the Photons that was working ok before remains working. It didn’t have to change networks during all this.

However, I am unable to connect any of the other Photons to any network. I even tried connecting to my neighbors network and it did the same thing. So I’m thinking that there may be something on the Particle back-end that is causing devices on my account to be dropped shortly after connecting.

You may want to reprogram your Photons to use dynamic IP again.
Since this is a sticky setting you need to flash some firmware that calls WiFi.useDynamicIP().

That way you can at least exclude one possible stumbling block from the list of obstacles.

This might be due to the fact that the Photon remembers up to 5 sets of WiFi credentials and hence fall back to one of these “historic” settings.

For your two orange blinks you may want to try again

particle keys server
particle keys doctor <deviceID>

Thank you all for the help! Since changing one of the failing Photons from static to dynamic IP it has remained connected. I haven’t reflashed all the other Photons yet, but I expect similar positive results there also.

3 Likes