Atom / Particle Dev no tree view, no folder loading

My Atom / Particle Dev installation (v.1.18) was working fine a few weeks ago but when I started it yesterday it was coming up with messages about project files being recovered and whether to merge into the current window or a new window. Neither made a difference. I also couldn’t open folders.

As far as I know, the only machine change is Windows 10 upgrading to the fall creators update (and Onedrive updating with it).

I reinstalled the latest Particle Dev v. 1.19. But having the same issue. When I open a folder the IDE is just blank. When I open a file, the file is there but there is no tree view of the rest of the directory. When I try to compile, it is looking for a project directory.

I can only get a project directory by creating a new file. Then it works until I compile, then the tree view disappears. Despite closing and saving the project, when I open up the IDE it again comes up with the new project now being recovered and the tree view is missing.

I then tried installing Atom directly, v.1.21.2 and installing the particle-dev-complete package. They all install except for particle-dev, which looks like a submitted issue. When looking at the output, there seems to be an issue with node-pre-gyp install --fallback-to-build. So from another thread here I did the following from an elevated command prompt: npm install --global --production windows-build-tools
However, that still didn’t fix the issue with it getting stuck on the node-pre-gyp.

I’ve tried uninstalling and reinstalling. Not fixing it.


PS: On a different Windows 10 machine the installation opens the same folders fine as a project. But it has its own weird thing that the code window loses the scrollbar after compiling and won’t even scroll on screen by cursor although I can see the line numbers change (but scrolls fine before compiling, tree view scrolls, settings scroll). That seems like a submitted issue too. But on 2 different machines I can’t manage to work on my project!

What it looks like when opening a folder…nothing:

Further testing I copied the directory to my C:\ and it opened fine from there. I’m suspecting some conflict with Onedrive. I tried setting the folder on Onedrive to “Always keep on my device” but with the same result.