Asset Tracker's Grove connector doesn't match Grove's cables


To me, it looks like that the Assets Tracker’s Grove connector doesn’t match the Grove sensor kits cables.
I am wondering, if I am missing something? Did I order the wrong Grove sensors?
Have anybody else tried to connect a Grove sensor to the asset tracker, and if so, how did you do it?
Do I need some sort of adaptor, or do I just try to cut the cables connector, so that they fit?

Maybe a trivial question, but I’m new at this hardware stuff.

Thank you in advance

Could you give us a link to which (Grove) product you bought? And maybe a picture of what your current setup looks like?

@axjensen, I think you are right. I’ve just tried it myself and the gap in the side of the receptacle is too small (4mm instead of 5mm).

@will, any thoughts?

e.g. AssetTracker v2 vs. SeeedStudio Grove LED driver

unless SeeedStudio have changed their standard (that LED driver is a few years old :wink: )

I’m trying the Grove - Temperature & Humidity Sensor ( SHT31 ), but I have maybe five different Grove sensors.
They all have the same connector.

Attached a picture of the Asset Tracker v2 shield, the connector and cable of the Grove sensor. Looks similar to ScruffR picture.

I tried to force the plug (sorry, maybe not the best strategy), and it felt as I could make connection without breaking anything. Will test it tomorrow.

Just grabbed the Grove kit and an asset tracker, and that seems to work alright.

1 Like

Obviously it’s the cables. Some seem to have the polarity protection ridges at the sides, some in the middle with a lock clip (5mm) and some don’t have any (bad cheapo idea IMHO).

You could shave off the ridges from your connectors (or get other cables), just watch the polarity then.
You could even pull off the receptacle housing to have a reversable solution, but be rather careful not to pull the pins off.

No idea why SeeedStudio opted for the cheapo cables while still use the “standard” receptacles for the Photon Starter kit :confused:

1 Like

Thanks Moors7 and ScruffR. Your suggestions helped me move along.

We’ll try to resolve this connector mismatch in the next run of asset trackers. Thank you for the feedback.