ARGON - WPA 2 ENT Authentication?


#1

Hi.
It appears that I CANNOT authenticate ARGONS via PEAP/MSCHAPv2 (WPA 2 ENT) Network as I do with the Photon.

Did I misread the capabilities of the ARGON ?

When will PARTICLE CLI provide complete support for ARGON/ XENON config?

Many thanks
slab


#2

@sensor I was just about to try myself but you beat me to it.

I am pleased to hear at last that some is able to get WPA2 Enterprise security on a photon working.

I have tried with various WAPs setup specifically for testing and all have failed. I have tried using CISCO Meraki with RADIUS server internal and a DrayTek Vigor AP. Would you mind describing the setup you are using (Device OS, outline of credentials setup and WAP settings, RADIUS server used).


#3

There is currently no support for WPA2 Enterprise on the Argon at this time. It is something we’d like to include in the future, but there is no specific schedule for it right now.


#4

Device OS: 7.0
I have successfully connected to my University’s WiFi Network, although I am not sure what RADIUS server is employed (possibly CISCO - I think).

Here is the output of connecting to the Uni WiFi:

$ particle serial wifi
? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: ConcordiaUniversity
? Should I try to auto-detect the wireless security type? Yes
> Detected WPA2(802.1x/AES/AES) security
? EAP Type PEAP/MSCHAPv2
? Username _my_user_name_
? Password _my_uni_pass_word_
? Outer identity (optional) _my_user_name_
? Would you like to provide CA certificate? Yes 
On macOS, I have configured nano as my Terminal Editor, at this stage nano is opens and I simply copy
and paste the PEM (University Cert) file contents to the nano -  save this as a temp file and is streamed
to the Photon via USBtoSerial

? CA certificate in PEM format Received
Done! Your device should now restart.

After that, Photon reboots and connects to the Uni WiFi


#5

Thank you for sharing - I have been trying without the Root CA certificate (optional) but it really does not like it. I will try nano as well.


#6

@rickkas7 Being that the needs of customers as reported subjectively on the forum may constitute one avenue, to be given the appropriate weight, by which Particle determines development priorities, I would like to contribute that my Particle Argon is absolutely useless to me in a particular location where I would like to use it, without the ability to have WPA2 Enterprise authentication supported.

Seeing as this thread I am bumping is 8 months old, is there any new and subsequent update on when this functionality can be anticipated?


#7

@Paul_M This thread is marked as having a solution - I share your frustration about the lack of news/progress on WPA Enterprise support on the Argon after 8 months. I have been quiet on the community generally about WPA Enterprise because I have been working with Particle Support on providing logs and testing the solutions being put forward. This week I have successfully connected to a WAP using WPA2 Enterprise - so progress is being made. This is on the Photon using the STM32. The Argon uses the ESP32 for WiFi but will no doubt use the WICED SDK which I understand is where the problems have occurred. Hopefully once the Photon solution is released the same can be ported to the Argon device OS.