Argon has no option to connect to unsecured network


#1

Hi, I teach at a university and use particle photons with my students to help learn instrumentation. We have been using particle photons with good success but were never able to use in class as there are over 100 students in the lecture. Wifi just wont work. We deal with it by not using them in class other than for the lecturer.

I am hoping the mesh products will allow some in class experimentation but so far I am having difficulty with the first step. Connecting an argon to wifi.

I just received my argon boards but they are unable to connect to the campus guest wifi. There is no options for open networks. I even tried using the serial port and “w” but there is no option for open networks?

I would request that support for this to be given as in my environment it is politically difficult to get anything other than an open network to connect devices like this to.


#2

You can use particel serial wifi

But I do see an unsecured option with the w parameter

Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2: 0
Security Cipher 1=AES, 2=TKIP, 3=AES+TKIP: 1
Thanks! Wait while I save those credentials...

The only thing that was a bit puzzling was the request to add a Security Cipher although 0=unsecured was selected. However, that parameter will be ignored.

What does your device report for particle identify (in Listening Mode)?
My Argon is running 0.8.0-rc.25


#3

I noticed the first time I try to setup the board it will let me do unsecured.
Once it has connected once if I try to add another it would not let me choose 0.

The option was gone.

Also it would never work in the IOS app. I had to use the serial terminal.


#4

Thanks for the feedback here. I will raise this issue with our mobile team and see what the best solution is. I don’t know of any reason why we wouldn’t allow connections to open networks, but will ask the team to jump in.


#5

The Android app supports unsecured networks currently. When you get to the password screen, just leave the password field blank and hit “next”.

The next release eliminates this awkward step and just skip the password screen for unsecured networks.


#6

What is the ETA for the fix? I am not able to connect the argon to the unsecured network.
As of yet the IOS app still asks for a password when connecting to the unsecured network and the continue button is disabled.


#7

@Raimis could you chime in on status of iOS?


#8

Hello, sorry that the unprotected wifi support was not there from the beginning. The iOS app version containing the fix for this is now undergoing internal testing. If all goes well it should go live within next couple of days. If we find something bad, it might get pushed to the end of January, but I really hope that won’t be the case.


#9

Let me know if you still have any issues connecting any type of wifi networks. The wifi security part was reviewed and now should support unprotected, WEP and WPA protected networks.