Use Argon without Wi-Fi and without setup

Continuing the discussions from
How to collect data with particle argon without Wi-Fi connection? and
Argon has no option to connect to unsecured network

I am teaching a college class with the Argon and we can’t set up the devices. We have two networks: one that requires individuals use their own username/password combo and a “guest” network that allows any computer or mobile device to connect to the internet without password. I was trying to use the latter as there’s no way to put a username (to my knowledge) into the Argon WiFi setup. But no students managed to set up their device successfully in class today using the guest network and mobile app. Nor could anyone claim a device without the app using the Web IDE (it wouldn’t accept any Device IDs).

I have used Electrons and Borons without cellular and had assumed that I could use the Argon without WiFi

I also tried code starting with the following to try to avoid Wi-Fi altogether:

SYSTEM_THREAD(ENABLED);
SYSTEM_MODE(SEMI_AUTOMATIC);

void setup()
{
  Particle.disconnect();
  WiFi.off();

in the hopes that we could use the microcontroller’s other capabilities without touching WiFi, but the Argon boots with green blinking followed by cyan strobing every time and the other functions won’t work.

FWIW, we’ll add in Wi-Fi or BLE capabilities at the end of the semester, but I wanted to ignore IoT for the first few weeks (while I figure out how to work around the university Wi-Fi limitations).

Any recommended workarounds to get us using these devices either with or without Wi-Fi? particle identify gives Your system firmware version is 5.0.0. Thanks.

You probably won’t be able to use Wi-Fi, because most network of this type either require WPA2 Enterprise Wi-Fi (username and password, RADIUS, and networks like EduRoam), or have a captive portal where you need to agree to terms to access the free Wi-Fi. Neither can be used with the Argon.

However, the Argon can be used for no Wi-Fi and BLE without setup and claiming. You don’t need either of the two commands you have in setup(), the default is off when using SEMI_AUTOMATIC or MANUAL mode.

The most likely reason the device is connecting to Wi-Fi is that there are missing system dependencies because when you compiled, a target Device OS version higher than what is on the device was specified (or the default, 2.3.0). The device probably came from the factory with 1.4.4 on it.

Two fixes are:

  • Upgrade the Device OS over USB using Device Restore USB or particle update.
  • Target the same version of Device OS that’s currently on the device.

If you want to troubleshoot the problem and make sure that’s the cause, you can use the Device Inspect Tool or particle serial inspect with the device in listening mode (blinking dark blue).

More tips here: I’m using manual mode but the device tries to connect to the cloud

1 Like

Thanks, @rickkas7, this seems to have worked. I really appreciate the quick and helpful reply.

A few details if anyone else stumbles onto this:

Prior to running particle update, particle identify gave me Your system firmware version is 5.0.0. After particle update, I get 2.3.0 (so update actually downgrades firmware—a bit surprising of an effect, but if it works it works!).

I also removed the Particle.disconnect(); and WiFi.off(); calls since you say they’re redundant with SYSTEM_MODE(SEMI_AUTOMATIC);.

Interestingly, we don’t have that for our guest network. That’s what I’ve seen at other universities, but here, it seems like it’s just an open guest network.

Thanks again!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.