Argon Pairing with the assisting device fails

argon
Tags: #<Tag:0x00007fe21e173290>

#1

I have two argons with this issue and it only has shown up recently. I start an Argon (no issues). Try to add a Xenon (tried two different ones, one known good, one new) and I get Pairing with the assisting device, and eventually Failed to connect to your mesh device Please Try again. I can connect to the Argon through the phone app without a problem (for “maintenance”).

Note 8 Android phone.

Thanks
-Joe


#2

Not sure why, but yesterday when I was attempting to pair my Xenon’s with an Argon I had to “Try Again” multiple times before it worked. It finally did work.


#3

Thanks, I’ve been doing that with no luck.

I’ve also unclaimed and reclaimed the devices.


#4

Which version of the app are you using? (You can check this by going to Settings -> Apps, tapping on the Particle app, and scrolling to the bottom of the screen)


#5

3.0.2

Also tried updating directly via USB leaves me with two Argons that are dead and only flash SOS and 10 blinks.

iMac-2032:downloads joes$ particle flash --usb argon-system-part1@1.2.1.bin
Flash success!
iMac-2032:downloads joes$ particle flash --usb argon-tinker@1.2.1.bin
Flash success!

***** NOTE I CANNOT GET THE DEVICE TO BLINK BLUE TRIED RESET TRIED RESET FACTORY***
****** Constant red SOS and 10 flashes (yes 10) ***********************************

iMac-2032:downloads joes$ particle flash --serial argon-bootloader@1.2.1.bin

! PROTIP: Hold the SETUP button on your device until it blinks blue!

? Press ENTER when your device is blinking BLUE

Error writing firmware: No serial port identified

iMac-2032:downloads joes$ particle serial inspect

Could not get inspect device: No serial port identified

iMac-2032:downloads joeslawsky$


#6

Just to try and understand your situation fully …

  1. Are you able to get the Xenon to flash Blue?
  2. Then you begin the add/pairing process?
  3. Are you prompted for the Mesh network to join?
  4. You then press and hold Setup on the Argon to get it blinking Blue?
  5. This is when you then get the error/timeout?

#7

FYI - It has been about a month or so now, working with tech support with an answer sometimes in 24 hours sometimes days.

My formally working Argon stopped working after an update and a brand new one failed as well

Now I have 2 Argons and 3 or 4 Xenons dead on my desk.

  1. Yes
  2. Yes (in one scenario)
  3. Yes
  4. No then the process hangs

I get the error from the Argon (or xenon) when I flash it with even Tinker


#8

To keep everyone up to date, I heard from Particle on the 25th (3 days ago) and was asked to put the Argon in Safe Mode

Got it to blink purple
Went to blinking blue.

waiting for next step


#9

Sent another email today to Particle support. It has been days since my last reply.

My working (for months) Argon is now dead since update
My new Argon is dead since update
my 5 Xenons, no idea since the Argons are dead.

The rest are still in boxes, no reason to open.

Email working with Tech Support basically an email every couple days been dealing with dead equipment for over a month. No urgency from Particle. Very disappointed.

One Argon and One Xenon were working wonderfully which prompted my investment in additional devices. Now, none work.


#10

When I try to join rejoin using the phone app this happened

And it flashes green,

AND it blinks SOS plus 14


#11

Disappointed, This was a great platform, I got a lot done in a short amount of time with great success until now.

I have now been without my development platform for over a month.

Does anyone else have these issues after an update?


#12

Asked to run:

particle update-cli (just to make sure you have the latest version of CLI)
particle usb dfu
particle update
particle usb dfu
particle flash --usb tinker
particle usb start-listening
particle serial wifi

So I
Put into DFU Mode.

iMac-2032:~ joe$ particle update-cli

Updating CLI… no plugins to update.

iMac-2032:~ joe$ particle usb dfu

Done.

iMac-2032:~ joe$ particle update

> Your device is ready for a system update.

> This process should take about 30 seconds. Here it goes!

! System firmware update successfully completed!

> Your device should now restart automatically.
Green Flashing
Green flash fast
Cyan flash fast
SOS 14 Red BLinks


#13

Hi @jslawsky:

Are you flashing particle flash --usb tinker after particle update? That is a critical part of the above request.


#14

You do not get that far
after the update, it starts SOS 14


#15

@jslawsky - after the update, place the device back in DFU mode and flash particle flash --usb tinker.

particle update does not overwrite application firmware, it overwrites Device OS only. you need to overwrite both in this instance, forcefully, by using DFU mode.


#16

Have you tried it?
If you did, you should have seen this

>particle flash --usb tinker

!!! I was unable to detect any devices in DFU mode...

> Your device will blink yellow when in DFU mode.
> If your device is not blinking yellow, please:

1) Press and hold both the RESET/RST and MODE/SETUP buttons simultaneously.

2) Release only the RESET/RST button while continuing to hold the MODE/SETUP button.

3) Release the MODE/SETUP button once the device begins to blink yellow.

Error writing firmware: No DFU device found

Which would align with what @marekparticle said


#17

Go into Particle app
Add mesh network rgb2
paired with xenon
select rgb2 network
scan sticker of Argon
pairing with the assisting device

Failed to connect with your mesh device

THis is what started this entire thread

Tried to flash a simle part of my code that has worked before into the ARGON and SOS 14 . Code Below

// This #include statement was automatically added by the Particle IDE.
#include <PietteTech_DHT.h>

// DHT22 Temprature Humidity Center Variables /////////////////////////////////////////////
#define DHTTYPE  DHT22       // Sensor type DHT11/21/22/AM2301/AM2302
#define DHTPIN   D2          // Digital pin for communications

PietteTech_DHT DHT(DHTPIN, DHTTYPE);
// DHT22 Temprature Humidity Center Variables End /////////////////////////////////////////


void setup()
{
  Serial.begin(9600); /* Define baud rate for serial communication */
  DHT.begin();  
}


void loop()
{
   //DHT 22
    int result = DHT.acquireAndWait(2000); // wait up to 1 sec (default indefinitely)
 
    switch (result) {
        case DHTLIB_OK:
            Particle.publish("Temprature / Humidity",String(DHT.getFahrenheit()) + " / " + String(DHT.getHumidity()), PRIVATE);
        break;
        default:
            Particle.publish("DHT22 (Temp/Humidity) Error",String(result), PRIVATE);
        break;
  }
      delay(10000);
}

#18

I believe an issue currently exists with the DHT library and Device OS post 1.2.1, in which memory allocation became explicitly forbidden in an ISR or Event Handler.


#19

OK I’ll try another simple code.

Still does not explain failure adding the xenon to the existing Argon.


#20

Please use the CLI:

https://docs.particle.io/support/particle-devices-faq/mesh-setup-over-usb/#xenon-mesh-node-setup

particle mesh add :xenonID :networkName

This wont work if the Argon isn’t breathing cyan.