Argon going offline (and other issues)

Hi all,
I’ve been working with my new Argon for a couple of days now.
Here’s some history of what I’ve done so you have an idea of what state it could be in now.

The first day I had issues flashing to it via CLI (couldn’t get it out of listening mode).

Yesterday I had issues re-claiming the device (I had unclaimed it on my Android app and could not claim it there or from CLI – even though the device was breathing cyan and connected to the internet).

Today I was able to reset the FW to Tinker and claim the device from the web ide (using the hex ID from particle serial list), which was great.
I then used the Web IDE to flash custom FW.
It worked, but now the device goes offline for no apparent reason within 2 minutes of a reset.
The board itself stays breathing cyan the whole time, so I don’t know why it’s doing that.
I tried flashing from CLI, same effect.
I noticed that even though the FW was updated, the Particle functions registered in the firmware did not update, and I could not publish new events from the app, even when the device was online.

I tried flashing tinker from CLI (via USB, since it keeps going offline).
The functions listed finally updated! (to analog/digital read/write)
Then I flashed my custom firmware again, but the functions list did not update…
and then it went offline again.

As a final note, throughout this process many of the usb and serial functions I have tried to use have been unresponsive (but not all – I’ve flashed firmware, I’ve configured wifi, I’ve reset, and I’ve listed serial connections)

Any advice on what to do to keep the argon alive and register it’s custom FW’s particle functions would be much appreciated. Same goes for getting more usb/serial functionality working.

Thanks!

(P.S. I’m running Ubuntu 18.04 and particle version 2.8.0)

Well,
After reviewing my own comment, it did seem like my FW could be the issue.
I reviewed it, and it looks like I had an infinite loop inside the loop() function.
Updating that and reflashing did fix my issue. It now recognizes the custom FW functions and stays online for longer than 2 minutes.

Although I am still having some serial/usb issues, I am happy that I can at least continue to develop my firmware :slight_smile: