Argon Cyan Flashing with One Red Flash Every 15 Seconds

When connecting the Argon device, I get 15 second intervals of cyan flashing with one red flash. I unclaimed Argon to see if reclaiming the device would help solve my issue, it did not. Now my computer cannot find the device, since it cannot connect to Device Cloud. Anyone have an idea? And this started because I tried to reset the keys when it was flashing cyan with three bursts of orange (which my Xenon state is in currently).

Welcome to the community.

Unclaiming a device for any other reason than to pass the device on to someone else is never helpful :wink:

I can’t quite see the connection between your computer not being able to find the device and the device not conneting to the cloud.
Are we talking about a USB connection between the device and the computer or WiFi or Bluetooth?

How did you try to do that?

Hi @ScruffR and thank you!

And well at the moment I believe wifi, since I’m not able to connect my Argon to the Particle Device Cloud.

When attempting to create with Mesh Network:
“Error: Your device failed to obtain an IP address. Please make sure your device has internet access.”

When attempting to create without a Mesh Network:
“Error: Your device could not connect to Device Cloud. Please try again.”

And the Argon device continues to flash cyan and on red flash.

And I followed someone else who had the same problem, I tried to do a factory reset by putting the Argon in DFU mode and update the particle keys on the device. But it did not work. So I unclaimed the device and attempted to reclaim it to see if that would reset the device.

Try the following

  • put your device in Listening Mode (blinking blue)
  • run particle identify (note device ID)
  • put device in DFU Mode
  • run `particle keys doctor
  • run particle keys server

This should get potential keys issues straight again.
Then see if your device can connect to the cloud again.

Sounds good:

  • I put device in Listening Mode
  • I ran particle identify (got device ID and version 1.2.1)
  • I put device in DFU Mode (blinking yellow)
  • ran particle keys doctor <device ID>
Make sure your device is in DFU mode (blinking yellow), and that your computer is online.: Error creating keys: Command failed: openssl ecparam -name prime256v1 -genkey -out <device ID>_ec_new.pem
ecparam: Can't open "<device ID>_ec_new.pem" for writing, Permission denied
  • Did not run last instruction due to error.

What do you suggest?

What OS are you using on your computer.
If Windows make sure to run these commands from a directory you have write permissions (particularly not from C:\Windows\System32 or other system directories).

Windows. And thank you, I wasn’t in admin mode and I switched into my Document folder to make sure.

  • ran particle keys doctor <device ID> again in DFU Mode (blinking yellow)
New Key Created!
Saved!
Saved!
attempting to add a new public key for device e00fce68700e68ade0025bea
submitting public key succeeded!
Okay!  New keys in place, your device should restart.

After the command above, what should I look for when it says my “device should restart” ? Because the Argon is still blinking yellow.

  • ran particle keys server
Okay!  New keys in place, your device will not restart.

I pressed [MODE] and [RESET] at the same time, and it started flashing green and now its breathing cyan again. I will attempt to connect now.

Just reset

So I was able to connect to the Particle Device Cloud now!
Argon’s behavior once it was connected:

  • rapid burst like cyan flashing
  • then the flashing cyan and a red flash pattern
  • and then the cyan breathing

I double checked sync by opening the Particle Web IDE and refreshing devices and selecting “Signal”, the color pattern was matching and I can flash my code again! Thank you very much for helping me!

2 Likes