Argon trouble with Quick Start - "Unable to find your mesh device"

I received my Argon today and am going through the quick start for its first use. It asked to update the firmware and proceeded, but this process crashed unexpectedly.

Now the unit cannot successfully connect, I keep receiving “Error, Unable to find your mesh device. Make sure the mesh device’s LED is blinking blue and that it’s not connected to any other devices”

The LED is flashing blue, how can I restore this unit to action? I have the Segger J-Link EDU, the Olimex OCD-H & a few other ICSP’s (TI, ST, etc.) if useful, to note.

Let me know your thoughts, eager to get this unit up and code running!

You can try press-hold MODE button for 10+seconds till it starts rapid flashing blue.
Then press-hold MODE again and tap RESET, wait till the RGB LED goes from magenta to yellow to white.
After that you can try again.

If that doesn’t help, you can download the system binaries and flash them via DFU Mode and CLI

Hi Scruff,
I tried the following a few times:

  1. Press-hold MODE button for 10+seconds till it starts rapid flashing blue
  2. Then press-hold MODE again and tap RESET
  3. Wait till the RGB LED goes from magenta to yellow to white
  4. Try again

This enabled connection from iPhone to Argon, but the Argon was not able to connect to the Particle Cloud -

Thoughts? Is there a DFU Mode reference to use for reflashing the Nordic?

There are some issues with WiFi connection to some router brands or setups that will be addressed in the upcoming device OS update rc.26.
If you can provide a video of the RGB LED behaviour while the device is trying to connect to WiFi and cloud we might be able to tell what the issue may be, but the cure will probably require rc.26.
A temporary workaround that worked for most people who are facing above mentioned issues was to connect to a mobile hotspot - these tend not to use IPv6 or expose “too many DNS” servers or send unsolicited DNS/nd6 packets :wink:
Also some special characters can’t currently be used in SSID and password (e.g. ,, /, …).

You can flash a valid binary via particle flash --usb <firmware.bin> -v

Here is a video of the flashing sequence -

We have an ARRIS NVG443B router from Frontier. What application (‘particle’?) is used to flash the binary?

This is what we here in this community call CLI
https://docs.particle.io/tutorials/developer-tools/cli/

1 Like

Hi Scruff,
These tools are great, thank you! They are not working though, I keep getting this response -

Thoughts? The Argon is flashing steady blue, and this termainl is connected online. I have also tried with PowerShell and Cygwin. See below for detailed reference on my procedure here -

Thoughts?

Does Windows (which version) show the device in DevMgr when it’s put in DFU Mode?
Can you show what the device returns when you put it in Listening Mode (blinking blue) and run particle serial inspect?

1 Like

The device is shown in Device Manager, here is a USBDeview report -

For ‘particle serial inspect’ I get -

>>C:\Users\justi\AppData\Local\particle\bin>particle serial inspect
Could not get inspect device: No serial port identified

No serial port is shown in device manager. Thoughts?

Is the device blinking blue when running particle serial inspect?

Can you post an image of your DevMgr window when the device is plugged in and blinking blue?

Here are the requested screenshots -

Thoughts? This unit was part of the initial pre-order launch, can I just return it for a new unit? My team ordered ten units much later on, I had my manager test one today and it worked just fine. Can I return this unit then and get a working one? Much simpler path to success I think

Since you seem to be able to use DFU Mode you should be able to update the device OS that way.

Download the system binary and the NetworkCoProcessor firmware
and apply via DFU Mode and

particle flash --usb system-part1-0.8.0-rc.25-argon.bin -v

After that you put the device in Listening Mode and flash

particle flash --serial argon-ncp-firmware-0.0.5-ota.bin -v

This should allow to run (in Listening Mode again)

particle serial wifi

to apply the WiFi credentials and get the device online.

Good news, working now!

My team had mailed me (3) of the new units we had just purchased, and I performed the attached procedure to get these each working. On completion, I then applied the same documented procedure (see below) to my personal device and it just worked, the first time.

Cool. ScruffR, thank you for your efforts and time here, I have learned much in our work together. And now moving forward, excited for my next steps in Argon dev too. Thank you much!! :slight_smile:

2 Likes