Argon can't connect through app

Nope, in this case it’s a xenon, and just trying to add the device before even adding it to the argon gateway

There is definitely an issue with the iPhone or ios or split-band wifi networks. I tried my new Argon several times with the same results as noted above - it gets all the way to entering my credentials, then an error pops up that the bluetooth is lost, and the Argon goes to rapid flashing green. I need to go to factory reset and start over (with the same results every time).

However, after turning off the phone wifi and using its hotspot instead of my home wifi, it connects fine.

I have a TP-Link Deco M5, which creates a 2.4/5GHz network. My SSID is all alphanumeric, and my password is like Abcdefghi1. Any other things to try to get it to join my home network?

I’m a newbie, so I’ll look up how to do the flash, and give it a try.

Hello everyone. I’m iOS developer at Particle. The Argon issue described in this thread sounds to me like a firmware issue, but I can’t confirm that just yet. What I know for sure is that the only time iOS app may drop connection is in ‘setup complete’ screen (after offering to add one more device to same mesh network). Any other connection drops are initiated from hardware side. Furthermore, @MrHofflich mentioned that he is seeing same issue on both iOS and Android devices which suggests that problem is definitely outside of mobile app.

Right now I am working on adding support for log sharing in iOS app. Next app release will include some minor UX improvements and new service screen (accessible by tapping ‘device list’ screen title 10 times) that will contain debug information for most recent app sessions that will be easy to share via email/airdrop. This won’t access device logs, but at least we will be able to see more insights in what is happening in the app which I hope will help us investigate some of these issues we are unable to reproduce in our environment. I assume this update will go live sometime towards middle of next week.

3 Likes

@robie1373 Thanks. Please note that the logs may contain sensitive info, such as your WiFi password, so you may want to change it before sharing the logs

1 Like

Thanks, for the iOS app what I did noticed is that after entering the credentials for the wifi, the argon started to flash green like trying to connect, but then in the app showed the error message shown in the original post, that did not happened in the android app (which I don’t know if the iOS is correct and the android is not), in other topics, the problem is attributed to a problem with IPv6 problem in the firmware. What I had to do in order to have it working is to deactivate the IPv6 from my connection, then use my laptop as a hotspot and connect through that. After that everything worked like a charm.

This is very valuable information. Not sure how well IPv6 is handled on firmware side (I think @sergey will comment on that when he sees this), but I have just checked that there was missing check for IPv6 address in iOS app. That missing check does not result in a error message, but app would fail to recognise device getting connected if it would (if device would start breathing cyan). Adding this right away and will ship it with next build.

4 Likes

Cool!! So glad I could help! Finally can give a little bit back to you guys! You are doing an amazing job! Keep it up!

2 Likes

This is a known issue (https://github.com/particle-iot/firmware/pull/1596) that is already fixed in our development branch (mesh-develop) and is slated to be included in the next release quite soon.

2 Likes

Well, changing the password for one without special characters did not work either. I changed one other thing and did not connect for mesh but WiFi only. That produces a slightly different infinite loop with slow green blinking lights, followed by fast green lights and then a long white LED. The long white is new. Progress? I don’t know. I’ll try a different Argon tomorrow. Still have high hopes that this will work. I need to put a bunch of sensors in a test place to see if I can use these for a class. Right now I think this blink pattern might look really nice on a Christmas tree if ai had a dozen in this blinking cycle.

Very frustrating !!! You need to setup a pinned thread that says that your products CANNOT be setup on a network with IPv6 until you release an update to your firmware. I have got to rant here, what cave network are you guys on? The world is on IPv6 as well as IPv4 now, if you want to be successful as an IoT company you have got to do better and get current! Not testing on an IPv6 network is a basic mistake that should not be made.

And when is ‘quite soon’? You need to put a date on it. Not being able to setup the product is not a small problem that can casually put off till ‘quite soon’.

Come on folks, do better if you want to be successful!

3 Likes

In my case, I’m pretty sure the issue is that the Argon can’t connect to my home WiFi, due to the fact that the 2.4ghz and 5ghz networks are on the same ssid.

I am unable to get it to connect to my home network using both the iOS app and the serial cli. Yet I can get it connect to my iPhones personal hotspot.

Since I am unable to turn off the 5ghz network, are there any other methods I could use? I would think that if it is a 2.4ghz radio it would connect to the 2.4ghz network without issue.

Is there a way to have the iOS app indicate the network frequency when scanning for networks? Maybe they could be listed separately?

Hi @barskey

The usual advice for Photons is to rename the 5GHz network to have different SSID. Normally this problem has a symptom such that your device can connect just fine for a random period of time when at some point the router tries to move your device to the 5GHz network and leaves the Photon in limbo that requires a reset to recover from.

That does not sound like what you are seeing.

I also have not heard about this problem with Argons, but it is possible.

Unfortunately, this is a mesh network, and hence there is no option to name the 2.4/5 GHz different, nor is there to turn one off.

Although I wonder - if the Argon is communicating on a 2.4GHz radio, surely on would think the router would be smart enough to keep it on a 2.4GHz channel rather than try to connect it to a 5GHz one.

So using an borrowed iPhone to setup the argon (Android doesn’t work), and creating a 2.5Ghz network with no IPv6 and a non-empty alphanumeric password I am getting stuck at the point that the device wants to connect to the network. It whines that the password is incorrect. Well, I have a bone dead simple password on this network and I’ve connected to that network using other devices. I am new to the particle so I am a little unclear as to what options I have. Is the app method of setting these up just DOA and I should hook up a serial port and try to get them setup and configured using the CLI? Is there a way to configure them over USB or BT that doesn’t involve the app?

For another IoT thing a year ago I split my home WiFi into two different SSIDs with different frequencies and different names. That was just cheap LED sting controllers. Obviously that did not help with the Argon so I am guessing it is a protocol issue. If others on the thread try splitting their networks please let me know the outcome. I will not be able to test a phone hotspot workaround until tomorrow. The current project will eventually be installed (if it ever works) at a research facility where I will not be able to alter the WiFi network much.

Right now the only way to set up a mesh is via the mobile apps (and yes, the Android app has issues on certain devices; this is being worked on). Eventually I expect you’ll be able to do it via the CLI. I’m hoping for something like

particle mesh create <gateway_deviceid> <meshname>
particle mesh add <deviceid> <meshname>

and so on.

1 Like

Hello,

I’ve got 3 Argon Kits and with all I have the same issue as mentioned in this post. After update of the firmware, the BT connection is lost, the device blinks green very fast. After hard reset it’s still the same issue.

While switching over to the ethernet featherwing I still encounter the same issue, BT is disconnecting during setup.

Any thoughts on hot to connect?

Regards, V.

1 Like

What kind of mobile device/OS version are you using?

I’m using Apple iPhone and iPad Pro with IOS 12.1. On both devices the same problem.
Tried these devices:

  • ARGON
  • BORON

Regards, V.