Any/Everything Command Pallet fails to run in VS Code?

Been running workbench since '19, and been having recent PC instability of late (i.e. random resets). These resets have somehow corrupted my VS Code Extensions resulting in failure modals as shown in the ensuing screenshot.

I’ve uninstalled, re-installed VS Code and all the Extensions to no avail… any clues appreciated in getting this operational again.

Thanks in advance.

Not sure what causes your specific issue but I typically can use Ctrl + Alt + P and run “Particle: Update CLI” to resolve any unusual behavior like this. It might be worth a try.

None of the Particle Commands operate, and all produce the same error modal as shown above.

Open a Terminal in VS Code (Terminal - New Terminal) and try:

particle update-cli

If that doesn’t work, try installing the Particle CLI again using the Windows CLI installer.

1 Like

Thanks… ran from the VS Code Power Shell and also ran the Windows CLI installer to no avail. Same error modal for anything/everything in the Particle Pallet.

Any other patches to attempt appreciated…

Is your home directory on a network volume, or does your Windows username contain a space or non-ASCII character (accented, etc.)?

Are you able to run the Particle: Audit Environment command? Not all of the tips in the post below will apply to your case, but it’s worth a quick check.

This Pallet command Particle: Audit Environment, like all others are inoperable and result in the same error modal as my initial post. My Home directory is on my workstation’s local SSD, and my Windows username is void of spaces and non-ASCII punctuation or symbols…

hey, I would try deleting (backup just in case) the .vscode folder under my home folder, which is where vs code stores its data and plugins (I think). Maybe uninstall VS Code before, delete the folder, then reinstall?
there are .vscode folders under the projects (where your source code is) maybe delete (backup just in case) that one too?
Cheers

2 Likes

Winner, winner, chicken dinner… uninstalling vscode, then wiping the .vscode folder, then re-installing workbench was the combo it needed. One would think that an uninstall would wipe the installed instance such that reinstalls are “fresh”. Thanks for the suggestion Gustavo! / @gusgonnet.

2 Likes

awesome! Happy to hear all is good.