Android Nexus 5 not discovering Photon

Hi I’ve got three new photons.
I’ve had one photon some time ago, which I used the ParticileAppAndroid/Nexus5 google reference platforrn to provision/setup and it worked.
Today tried using the Nexus5 to add a Photon - and it could NOT do it. The wifi network is visible Photon-KGB9 on a WiFi analyzer app, but couldn’t be discovered
Installed the app on tablet - Samsung SM-P600 - and it works OK.
So just to check uninstalled the Nexus5 app, and reinstalled and tried again on one of the other unprovisioned Photons - still couldn’t see it.

There are a few threads about problems with Nexus 5 - maybe there are some hints to be found

Maybe disabling the 5GHz band is an option.

Thanks - its an FYI - and seems like there should be option to invoke the earlier way of doing it as well. It worked for my first photon and was very impressive.
I also have problems connecting the Photon over node.js/USB - this has been very painful. I want node.js as I plan to move onto using an electron.