Adventures in Troubleshooting: Spark Core edition [Achievement Unlocked!]

I got a Spark Core during the kickstarter campaign long ago, but it turned out that my phone couldn’t run the app. Life happened, and I kinda forgot about it. Recently, I got a new phone. Installed the app, got the Core powered up, ran the smart config.

No Cores found.

At this point, I wanted to see it go. I have project ideas in mind and everything. So, after reading the docs and some forum threads, I have tried the following. The best I’ve been able to do so far is getting the light to breathe cyan twice like it was going to connect to the network, then sit at a solid magenta.

So, here’s what I’ve done so far…

With core in listening mode / flashing blue

C:\derp>spark serial list
Found 1 core(s) connected via serial:
1:      COM3

Additionally in this mode -

C:\derp>spark setup wifi
Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2: 3
Wifi Password: [REDACTED]
Attempting to configure wifi on COM3
I said: w
Serial said: SSID:
I said: [REDACTED]
Serial said: [REDACTED]
timed out on Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2:
timed out on Spark <3 you!
Something went wrong Serial prompt timed out - Please try restarting your core

Rebooted core.

Used putty to connect directly.

Your core id is [REDACTED]
Password: [REDACTED]
Thanks! Wait about 7 seconds while I save those credentials...
Awesome. Now we'll connect!
If you see a pulsing cyan light, your Spark Core
has connected to the Cloud and is ready to go!
If your LED flashes red or you encounter any other problems,
visit to debug.
    Spark <3 you!

After putting in my SSID and pressing enter, all leds on the Core went out. After it completed, the Core rebooted, breathed cyan twice, and now sat there with a magenta light.

So then I thought, “Well, maybe it needs a firmware update?” Or at least that updating the firmware would straighten out whatever was wrong with it. So…

With Core in DFU mode / Flashing yellow (at least I think it’s yellow, looks like there is a green and a red light flashing at the same time)-

C:\derp>spark flash --usb deep_update_2014_06
Apparently I didn't find a DFU device? util said
Error writing firmware... no dfu device found.

Note: With or without the Zadig driver installed, the Core does not show as connected in device manager while in this mode.

I’m out of ideas for further troubleshooting. I’ve actually done all this twice, with a factory reset in the middle.


Hi @blakeateit,

have you run through this setup

if you run the cmd dfu-util -l do you get list of dfu devices?

1 Like

Yep. That fixed it. Ended up running deepupdate, and fiddling with it some more, but now it seems to be working correctly.

Claimed and everything…



Cool no problem

1 Like