5 borons - green blinking forever and ever

One of these two errors keeps happening:

0000092240 [system] WARN: Internet test failed: DNS
0000092240 [system] WARN: Handling cloud error: 2
0000092339 [system] INFO: Cloud: connecting
0000092342 [system] ERROR: Failed to load session data from persistent storage
0000108240 [system] ERROR: Failed to determine server address
0000108240 [system] WARN: Cloud socket connection failed: -230
0000003115 [app] INFO: Cell On
0000003116 [system.nm] INFO: State changed: DISABLED -> IFACE_DOWN
0000003120 [system.nm] INFO: State changed: IFACE_DOWN -> IFACE_REQUEST_UP
0000003121 [system.nm] INFO: State changed: IFACE_REQUEST_UP -> IFACE_UP
0000041046 [ncp.client] INFO: Using internal SIM card
0000042096 [mux] INFO: Starting GSM07.10 muxer
0000042096 [mux] INFO: Openning mux channel 0
0000042097 [mux] INFO: GSM07.10 muxer thread started
0000042101 [mux] INFO: Openning mux channel 1
0000198319 [system.nm] INFO: State changed: IFACE_UP -> IFACE_REQUEST_DOWN
0000198320 [system.nm] INFO: State changed: IFACE_REQUEST_DOWN -> IFACE_DOWN
0000198322 [net.pppncp] ERROR: Failed to initialize cellular NCP client: -210
0000198324 [system.nm] INFO: State changed: IFACE_DOWN -> DISABLED
0000198428 [mux] INFO: Stopping GSM07.10 muxer
0000198428 [mux] INFO: Gracefully stopping GSM07.10 muxer
0000198428 [mux] INFO: Closing all muxed channels
0000198429 [mux] INFO: Closing mux channel 1
0000198429 [mux] INFO: Muxed channel 2 already closed
0000198430 [mux] INFO: Muxed channel 3 already closed
0000198430 [mux] INFO: Muxed channel 4 already closed
0000198431 [mux] INFO: GSM07.10 muxer thread exiting
0000198431 [mux] INFO: GSM07.10 muxer stopped

I have 5 borons here that have been working mostly okay at my house for the past few weeks as I prototype. They’ve been flaky at times, but my reconnect / backoff has worked fine enough.

Now they appear to be completely stuck? One of them fairly consistently behaves and connects eventually, but the rest are just stuck blinking green.

I have flashed from 2.0.1 to the new 3.0.0 as well as used the manual flash process to flash the bsom-system-part1 / bootloader / tinker to rule out my own code.

A few minutes ago, I decided just to pack them up and drove them downtown, they all pretty much instantly connected… So maybe I’m in a flaky spot suddenly? :roll_eyes:

Anything else I can try?? Is there some kind of guide for flaky connections or antenna tips or something?

Or is there a way to use the new 3.0.0 firmware to console / read my signal quality to be able to determine if it’s worth trying to connect? Query cellular signal while module tries to register by keeramis · Pull Request #2232 · particle-iot/device-os · GitHub (reference)

2021-04-12_23_41_24
If you look closely enough into this low quality gif you can almost see my soul breaking, also a banana


This is from my phone sitting right next to them.
Finally, as you can see- the antenna is quite unencumbered by anything at the moment and still having problems.

I tried submitting a ticket but the useless form at https://support.particle.io/hc/en-us/requests
literally just refreshes the page when I hit submit.

Here are the debugging logs as requested, maybe someone here can help

Have you looked at your browser console logs to see what may be amiss with the support page?
Could it be an over-zealous add-blocker?

@marekparticle, could you take this one?

Thanks @ScruffR.

@tunahammer - I am not able to reproduce the ticket submission issue. Are you attempting to log in to the support page? At present that is not supported.

Can you please:

a) Open another browser and try and reproduce.
b) Attempt to reproduce with Chrome. Right-click anywhere on your browser page and select “Inspect” then navigate to the “Console” within the window that pops up. Attempt to submit a ticket and please produce for me any errors or notices that appear within that window.

1 Like

@tunahammer ,

Very sorry to hear you are having these issues. In your phone screen shot, I noticed the carrier is Verizon. Do you have a way to check AT&T or T-Mobile as Particle devices do not use the Verizon network.

Thanks, Chip

I figured out what it was the question box that asked about the cloud debugger logs was paragraph format which made me think that I should paste my logs in there so when I did and hit submit it didn’t air out and it didn’t give any indication of an error in the chrome inspect logs either.
When I just deleted the logs from that field the ticket submitted just fine.
It would be helpful though for some error handling on the form to tell me I’d exceeded the max characters.

GREAT to know @tunahammer! I’ll add a little flag under the box that points future users to this issue.

1 Like