Boron LTE Continuously Flashing Green - Won't come online

Hello, I have several Boron LTE modules that are stuck flashing green for over a week. I have tried everything, referred to these posts where @mstanley , @ScruffR and @Dave have chimed in.

The issue still persists :frowning: .

I have attached the logs from cloud-debugging from my Boron (LTE) below. I have 10+ borons stuck in an infinite ‘cellular.ready()’ mode, ie, always flashing green. Please help debug:

0001084944 [ncp.at] TRACE: > AT
0001085944 [ncp.at] TRACE: > AT
0001086944 [ncp.at] TRACE: > AT
0001087944 [ncp.at] TRACE: > AT
0001088944 [ncp.at] TRACE: > AT
0001088949 [ncp.at] TRACE: < OK
0001088949 [ncp.client] TRACE: NCP ready to accept AT commands
0001088950 [ncp.at] TRACE: > ATI9
0001088955 [ncp.at] TRACE: < OK
0001088955 [ncp.client] TRACE: App firmware: 200
0001088956 [ncp.at] TRACE: > AT+UGPIOC?
0001088962 [ncp.at] TRACE: < +UGPIOC:
0001088967 [ncp.at] TRACE: < OK
0001088967 [ncp.at] TRACE: > AT+UGPIOR=23
0001088974 [ncp.at] TRACE: < +UGPIOR: 23,0
0001088975 [ncp.at] TRACE: < OK
0001088975 [ncp.client] INFO: Using external Nano SIM card
0001088975 [ncp.at] TRACE: > AT+CPIN?
0001088983 [ncp.at] TRACE: < +CME ERROR: SIM not inserted
0001089983 [ncp.at] TRACE: > AT+CPIN?
0001089991 [ncp.at] TRACE: < +CME ERROR: SIM not inserted
0001090991 [ncp.at] TRACE: > AT+CPIN?
0001090999 [ncp.at] TRACE: < +CME ERROR: SIM not inserted
0001091999 [ncp.at] TRACE: > AT+CPIN?
0001092007 [ncp.at] TRACE: < +CME ERROR: SIM not inserted
0001093007 [ncp.at] TRACE: > AT+CPIN?
0001093015 [ncp.at] TRACE: < +CME ERROR: SIM not inserted
0001094015 [ncp.at] TRACE: > AT+CPIN?
0001094023 [ncp.at] TRACE: < +CME ERROR: SIM not inserted
0001095023 [ncp.at] TRACE: > AT+CPIN?
0001095031 [ncp.at] TRACE: < +CME ERROR: SIM not inserted
0001096031 [ncp.at] TRACE: > AT+CPIN?
0001096039 [ncp.at] TRACE: < +CME ERROR: SIM not inserted
0001097039 [ncp.at] TRACE: > AT+CPIN?
0001097047 [ncp.at] TRACE: < +CME ERROR: SIM not inserted
0001098047 [ncp.at] TRACE: > AT+CPIN?
0001098055 [ncp.at] TRACE: < +CME ERROR: SIM not inserted
0001099055 [ncp.client] ERROR: Failed to perform early initialization
0001099055 [ncp.client] TRACE: Setting UART voltage translator state 0
0001099056 [ncp.client] TRACE: Hard resetting the modem
0001099056 [ncp.client] TRACE: Modem waiting up to 30s to power off with PWR_UC...
0001129957 [net.pppncp] TRACE: NCP event 3
0001129957 [net.pppncp] TRACE: NCP power state changed: IF_POWER_STATE_DOWN
0001129957 [system.nm] TRACE: Interface 4 power state changed: 1
0001129958 [ncp.client] TRACE: Deinit modem serial.
0001129958 [net.pppncp] ERROR: Failed to initialize cellular NCP client: -210
0001130059 [net.pppncp] TRACE: NCP event 3
0001130059 [net.pppncp] TRACE: NCP power state changed: IF_POWER_STATE_POWERING_UP
0001130059 [system.nm] TRACE: Interface 4 power state changed: 4
0001130060 [ncp.client] TRACE: Powering modem on
0001130210 [net.pppncp] TRACE: NCP event 3
0001130210 [net.pppncp] TRACE: NCP power state changed: IF_POWER_STATE_UP
0001130210 [system.nm] TRACE: Interface 4 power state changed: 2
0001130211 [ncp.client] TRACE: Modem powered on
0001130211 [ncp.client] TRACE: Setting UART voltage translator state 1
0001130311 [ncp.client] TRACE: Setting UART voltage translator state 0
0001130411 [ncp.client] TRACE: Setting UART voltage translator state 1
0001131412 [ncp.at] TRACE: > AT

I am NOT using any 3rd party external SIM. Just the default SIM that comes with the Boron dev board.

Appreciate your help.
-Arch

The log suggests that your device thinks it should use the external SIM.

To convince it into using the internal SIM you need to explicitly tell it to.
A simple way to do that is by flashing a dummy sketch like this

void startup() {
  Cellular.clearCredentials();
  Cellular.setActiveSim(INTERNAL_SIM);
}

STARTUP(startup());

SerialLogHandler logger(LOG_LEVEL_ALL);

void setup() {}
void loop() {}

After that you should be able to flash your default firmware again.

1 Like

Btw same problem here. Many devices randomly dying on the field and stuck in green blinking mode. No external sim.

I have a device that worked fine yesterday, powered it on just a few minutes ago and blinking green. Nothing changed and has been working fine. Is there’s some other issue going on?

Could this be related to the new plans? Have you exceeded your 100K monthly ops?

Me, I have not. I haven’t even hit 1k. I’ll never hit 100k with the devices I currently have.

No, I have not exceeded the monthly ops.

Same here, this has happened before the new plan, and both on old and fresh devices.

This is actually a bit concerning. I have multiple devices now that were working but are now just flashing green. They won’t even enter safe mode or DFU, it’s switches back to a green flash.

I have some unopened Borons that I can activate and see how they behave. But I have a number of devices assembled that are about to go out to people and now I’m going to have to hold off in case this is going to end up happening to them as well.

All of the impacted devices are running 2.0.1

UPDATE: Same one seems to be working completely fine now. I’ll just keep monitoring things for a few days. Hopefully everyone else’s are working now as well.

It’s back to just blinking green again. I know I’m not the OP, but it looked like others had a similar issue so I’m following up in this thread.

Entering DFU and flashing with literally the exact same sketch ends up putting it into safe mode (?) then if I flash (the same sketch) via the web IDE (so cellular working) it starts working again. I’ll have to dig deeper and see what’s going on. I can’t ask the people these will be going to to put the device in DFU and install the Particle CLI and flash, they’re not technical people.