Xenon setup fails with "Device not found" on mobile, "particle doctor" in CLI returns firmware error

Hi all, I am having trouble setting up one of the 3 Xenon’s that I just received in the mail.

When trying to set it up on the mobile device, it goes through the setup process and successfully pairs with the phone, and then immediately comes up with the error “Device not found”

I tried using the particle CLI tool with the following command: “Particle Doctor” And was able to successfully enter DFU mode with the device, but then ran into the error: “The Doctor didn’t complete sucesfully. Error writing firmware: file does not exist and no known app found.”

Anyone know what I should do next?

The Particle Device Doctor does not currently work with mesh devices, so that won’t be helpful.

What gateway device are you using? Xenon+Ethernet, Argon, or Boron. You need to set that up before you can set up a Xenon mesh.

It is not currently possible to set up a Xenon without a gateway.

I am using a Boron for the Gateway, but it doesn’t even get past the point where I can configure the device with my iPhone. Please see the list of screenshots below. The device seems to disconnect shortly after scanning the QR code with the mobile setup app.

Anyone? I tried setting it up with an android device with a similar disconnect error before updating the Xenon and connecting to the Gateway device.

Can you try doing the firmware upgrade again manually with instructions from https://docs.particle.io/support/troubleshooting/firmware-upgrades/boron/#manual-firmware-update

and in listening mode, do a particle serial inspect to make sure that everything passes

I’ve already done that and it reports fine when I do particle serial inspect

I have flashed firmware, tried setup using an android and two different iPhones. Two of the three Xenon’s that I purchased are working flawlessly, this one is just not functional. Can I get an RMA for a new one please?

FWIF, I flashed hybrid-0.8.0-rc.25-xenon when I reflashed the device.

For that you’d need to file a support ticket.

Alright, thanks. Just filed one. Anything else I can try besides re-re-re-flashing the board again and trying to setup with other mobile devices? I reiterate that the other two boards were very simple to setup on the first try and are working fine in mesh mode with a Boron acting as the gateway, so I think there’s something wrong with this particular device at the hardware level.