Xenon mesh setup hangs on "Requesting permission..."


#1

I have a Xenon acting as a gateway with the Ethernet featherwing, running 0.8.0-rc.27. Setup went smoothly, including setting up a mesh network.

I am now attempting to set up an additional Xenon and add it to the mesh. Setup goes smoothly until I get to the screen “Your Xenon is joining the mesh network”, where it hangs on "Requesting permission from assisting device to add Xenon.

I have tried adding the second Xenon to the mesh both from the mesh setup and the second device setup. I have updated the second Xenon to 0.8.0-rc.27 over USB from the CLI. Whichever way I do it, I get stuck at this step.

What am I missing here?


#2

You have put both devices blinking blue and scanned the data matrix of the second Xenon when you were asked to?


#3

Yes, I followed the instructions exactly.


#4

For the record, I had the same error message when adding a Xenon to an Argon. I performed the same process again and the 2nd time it worked.


#5

Still haven’t been past that screen.

I will say that the internet connection the Xenon ethernet gateway uses is spotty at best (at my local makerspace with slow wifi, through the ethernet port on a cheap repeater.). It disconnects and reconnects fairly regularly.

Now that I’ve got my Boron up and running I’ll try setting up a mesh with that instead, and then try the xenon ethernet gateway at home.


#6

Has this issue been resolved?

I’ve tried multiple Xenons to connect to my current mesh network and always hangs on Requesting permission.

Current mesh consists of one argon and one xenon. The Argon is kind o in an annoying place to get to at the moment, so I’d like to use the existing Xenon as my helper… Does this just not work?


#7

I’ve setup about 7 Xenons today and failed more times than I succeeded, but I kept retrying and eventually the same repeated procedure worked. Once it started working for one the others started succeeding too.


#8

I’m having more success using the particle command line interface to pair xenons with argons.

The commands were apparently added in v1.40.0.

From the reference docs:

particle mesh add <new device> <assisting device> [--password=...] [--yes]

Both devices have to be connected to the same computer via USB, both flashing blue lights in ready mode.


#9

One of my xenons continues to fail at this same point using the android app. I’ve done maybe 7-10 tries, waiting 1/2 hour or more for it to complete…

Repeating the process really can’t be the answer.

Using the CLI produces the the following error: Unable to open USB device: LIBUSB_ERROR_NOT_FOUND I checked the version of the CLI; it was the most recent… Both devices blinking blue.

There’s a little bit of documentation in the CLI itself under >particle help mesh add that explains what the -yes option is, but still can’t get it to work


#10

This is very frustrating. I got mine back in november and about every 3 months I try to play around with them but they are so irritating I give up and move on. I have 4 devices total plus accessories so I don’t want to just scrap everything. I hate that the devices can’t be partially paired, it’s a full reset every time.


#11

Have you tried the latest CLI which features these commands now

C:\>particle mesh --help
Manage mesh networks
Usage: particle mesh <command>
Help:  particle help mesh <command>

Commands:
  create  Create a new network
  add     Add a device to a network
  remove  Remove a device from its network
  list    List all networks and their member devices
  info    Get information about the current device's network
  scan    Scan for networks

(unfortunately Windows users still have to wait a bit for better drivers)