Will not complete setup via app [SOLVED]

Alright, describing colors in text is evidently not working. If possible, upload the video to youtube and post the link here. A dropbox link, or a google drive link should also work. If neither of those is available, try mailing it to support (at) particle.io If so, do reference this thread so they know what it’s about.

With the steps described in my first post, you should be able to get to breathing (not blinking) cyan, which is a mix of red and blue. (I often find it easier to differentiate between colors when I place a thin paper sheet over the LED, diffusing the colors. That makes it more uniform.)
So, the LED shout be breathing cyan, regardless of whether it’s been claimed or not.

Here are the steps I take for a device that’s in blinking blue mode on startup, thus without credentials. It’s also unclaimed.

  • place it in DFU mode by holding setup, and pressing reset. Hold setup until blinking yellow:

  • Device should now be in blinking blue mode (listening mode). Copy the deviceID for later.

  • With the Photon still in blinking blue:

  • To be very sure there’s no user application on there messing with the LED, place it in DFU mode again:

  • Now, it should be breathing cyan (green/blue):

  • It now shows up when I do a particle list:
1 Like

Try the link below

It should give an idea of the initial behavior. I can do a longer sequence if needed. I’ve followed much the same sequence you’ve listed:

npm update -g particle-cli
particle update
particle flash --usb tinker
particle login
particle serial wifi

DFU mode or setup mode in the appropriate places. At this point, the LED shows what you see in the video (no breathing). After holding the setup button until it’s blinking blue, the ‘particle identify’ returns a device id, the ‘device add’ fails, and a ‘particle list’ returns “No devices found” so it is certainly stuck somewhere. Hope the vid helps.


YES! “A picture speaks a thousand words”, that video certainly helped!

It’s the ‘blinking orange’ issue as far as I’m able to tell from the video :smile: That means that, somehow, your key probably got corrupted. Not to worry, there a solution for that :smile:
First, back-up your current key, you know, just in case…

Then, get yourself some new keys:

In Theory, that should fix the issue. Give it a try, and let me know if that worked for you :smile:

1 Like

Backing up the keys resulted in

C:\Projects>particle keys save mykey.der
running dfu-util -l
Found DFU device 2b04:d006
running dfu-util -d 2b04:d006 -a 1 -s 34:612 -U mykey.der
running openssl rsa -in mykey.der -inform DER -pubout  -out mykey.pub.pem
Error saving key from device... Error: Command failed: C:\Windows\system32\cmd.e
xe /s /c "openssl rsa -in mykey.der -inform DER -pubout  -out mykey.pub.pem"
unable to load Private Key
10224:error:0D07207B:asn1 encoding routines:ASN1_get_object:header too long:./c
... (rest deleted for space)

Having little to lose, I went ahead with the 'particle keys doctor ’ command which printed “New Key Created!” followed by several failures to save the keys (similar “header too long” error messages as the previous command). The message “Unable to load Private Key” was repeated three times in the output.

The ‘particle keys send’ command did succeed but ‘particle list’ and ‘particle device add’ do not. LED behavior remains the same. The .new.pub.pem file, if it is valid:

It does not look as though this guy is going to recover. Any other thoughts?


Ah yes, since it might be pertinent, the version of OpenSSL I have is 0.9.8 rather than the latest 1.0.x source available online.


can you try upgrading OpenSSL? I have the recommendation here: Tutorial: Particle-cli on Windows [07 Jun 2015]

Let me know? :smile:

Alack alas, no luck with the latest openssl version. Same error messages as before. I know that a factory reset risks bricking the board, but would it restore a valid key or was the key corrupted when the board was originally factory flashed?


No no. I don’t think it does and there’s no point in factory resetting for now.

May i know what’s your issue to give more concrete advice?

The Photon board would not connect out of the box, and the cause seems to be corrupt encryption keys. I’ve followed the instructions to backup and re-create keys, but the commands fail with openssl errors. It seems that any command to retrieve keys from the device encounter problems with the header length/format. As yet, no luck in getting the board to connect to the cloud and register itself.



What is the status of the RGB led? Flashing cyan with occasional orange?

There’s a video at

Ok cool.

That’s a little trick to solve with your situation.

Here’s a dummy public keys file: https://dl.dropboxusercontent.com/u/36134145/particle/junk.pub.pem

Can you download and do a particle keys send DEVICEID junk.pub.pem. Be sure to replace it with the actual deviceID and once you do that, reset the Photon and it should work.

I did the above in DFU mode, then reset the board. No change in the LED behavior. After a ‘particle login’ and ‘particle serial wifi’ command, the board remains in the same state as before. I’m also seeing the same error messages when trying to back up the keys. It doesn’t look as though the corrupt keys were replaced.


You dont need to be in DFU mode to run that command. That will simply send a public key to the :cloud:

Did you get something like successfully submitted a public key?

Yes, I got a “submitting public key…” message followed by “submitting public key succeeded!” Same message in DFU mode and setup mode. I also tried the command after the board was reset. No apparent change in behavior. Will the app recognize the board?

Ok so is it still blinking cyan with occasional orange?

Yes, same pattern as the video…


1 Like

OK, I do believe the board is now “breathing” (slow rise and fall of blue). Connect via USB or app?


It sounds like you have breathing cyan (https://docs.particle.io/support/troubleshooting-support/photon/#led-colors-explained-) which means the device is successfully connected to the :cloud: