Wifi updates on photon very unreliable

Just spent about two hours just trying to bring a photon back to life after hitting SETUP button for 3 seconds.
The particle app would constantly display errors.
Particle doctor would also say it could not finish despite following the exact steps mentioned.
My wifi is strong and stable, and I tried also with a hotspot, same bad results.

Also, the softAP script is the most unreliable thing. It does not work and I dont find any way to debug it.
Available memory is short? maybe, I dont know hoy much is enough. And it worked well before, why not now?

Is the latest firmware stable and performing well? I have three photons here doing the exact same thing. Im tired and worried about this since we plan to launch a product next week and this happens…

thanks for your help.

now it got even worse… this is all I get always:

Put the device in DFU mode

Tap RESET/RST while holding MODE/SETUP until the device blinks yellow.

? Select Continue when ready Continue

The Doctor didn’t complete successfully. Cannot destructure property ‘protocol’ of ‘undefined’ as it is undefined.

Please visit our community forums for help with this error:

https://community.particle.io/

After making sure your CLI is up to date, try
particle update
followed by
particle flash --usb tinker
Both while in DFU mode.

See if that helps?

1 Like

Instead of using Particle Doctor to set WiFi creds, you can use particle wifi (while in Listening Mode) and don’t use automatic scanning.

2 Likes

HI @plusmartin -

I can agree with both @ScruffR and @Moors7 on steps to try. I recently had a problem with two Photons, one I managed to salvage using the steps below:

  • Put the device in DFU Mode

  • Download and flash the following files using particle flash --usb through the CLI after making sure CLI is up to date:

i.e. particle flash --usb photon-bootloader@1.5+lto.bin

  1. photon-system-part1@1.5.bin
  2. photon-system-part2@1.5.bin
  3. photon-bootloader@1.5.0+lto.bin
  4. photon-tinker@1.5.0.bin

After these steps your Photon should be back to factory settings. If not, I am afraid as with my second Photon, a debug shield might be the way to go.

Even though Particle Doctor used to serve me well in the past, I experienced the exact same problems you did on both Photons.

Hope this helps!
Regards, Friedl.

thanks guys.

I did manage to reflash the photon but it still feels very unstable. When trying to program something OTA, sometimes it does it quickly and other times it takes forever…

I also have a huge issue with the softAP but I will ask this on another question.

HI @plusmartin -

This was exactly my problem on the one Photon, OTA did work, well sort of. It indicated successful flashes but the Photon did not respond as expected.

Did you manually flash it as I described, the firmware and bootloader? Successfully running Particle Doctor (without Auto-scanning WiFi as this messed up the process) also did not work. Manually flashing all four these files via CLI (either using Workbench or Terminal on OSx) is the only thing that fixed it.

Hope this helps.

Regards,
Friedl.

1 Like

A possible cause is your running app is not giving enough resource to DeviceOS.

When you get an issue downloading your app, try putting the device in SAFE MODE first. Report back on your findings!