Weird Way to get out from safe mode

Hi,

I want to share on what happen with my Particle Photon.
At first, my Photon do a standard process after being switch on.
I started to upload my new code. Suddenly, my Photon turn to safe mode by itself (magenta led color blinking). I tried to reset and switch off and on back. But, still in magenta color where I cannot upload any code. For information I’m using the Particle web IDE.

Then, I leave it for a week…
Now when I’m switch it on, my Photon came back to its standard behavior.

Does anyone can share on what has happened with my Photon?

You’ve probably tried flashing code with a higher user version than the system version that was on the device. In that case, Safe Mode Healer will be activated, which will update your system version. Try letting it do it’s thing for a couple of minutes, since it takes a bit longer than a normal flash.
The led should be blinking magenta too, not only breathing, to indicate it is flashing. It will also reboot a couple of times in the process.

2 Likes

Ooo… I see… Thank you for the info…:grinning: :+1:

Are you saying that my particle web IDE has the higher version than in the system?
If yes, is there any way that I can downgrade the IDE version?

You can select the target version you want to build for.

1 Like

Oh, I see…
Alright thank you @Moors7 and @ScruffR

1 Like