Photon is stuck in safe mode [Resolved]

I have a Photon that has been working well for a while, but yesterday I flashed some very simple code to it, and it entered into safe mode. Now, whenever I supply power to it, it connects and then instantly goes into safe mode, and same with flashing anything to it. However, the LED will randomly turn off and back on to magenta again, and occasionally the device restarts. If I try to manually put the device into safe mode, it just restarts as soon as I release the buttons. I can put it into DFU mode, and I have tried updating it with the CLI, but to no avail. Any help in fixing this would be greatly appreciated.

@ArtiSchmidt which system firmware are you selecting? Can you do a particle serial inspect to see if everything passes?

1 Like

Have you tried

particle update
particle flash --usb tinker

in DFU mode?
What version CLI were you using? Current is 1.17.0!


I plugged in my Photon today and it is working perfectly. I have no idea what was happening before, but everything seems fine now. Thank you anyway though to @ScruffR, I tried what you had suggested with version 1.15.0 of the CLI when it was not working, but unfortunately that did not fix anything. Also thank you to @kennethlimcp for your suggestion, I tried it and everything looked fine.


Let us know if you run into this problem again.