VSCode leaves Argon Stuck Yellow (DFU Mode), WebIDE Works

argon
Tags: #<Tag:0x00007f038d3cd9c0>

#1

So now I have my Argon & 3x Xenons working and linked correctly, I compiled the test code in VSCode for the Xenons and it deploys and works perfectly. If I compile it for Argon (changing the code workspace)

"particle.targetDevice"
"particle.targetPlatform": "argon"

and put the device into DFU mode it flashes and stays yellow. Resetting it returns to yellow as per other threads.

However, If I then flash it back to base with particle flash --usb hybrid-0.8.0-rc.27-argon.bin then it is back to normal. Now if I cut the code from VSCode and paste it as is to the WebIDE and flash it works perfectly. I can see in the VSCode it is targetting the argon not a xenon in the CC compiler output so I know the settings have changed.

It’s working for now but I am back to using the WebIDE again at least for the Argon.


Exit DFU mode on Argon?
#2

The hybrid firmware is only for initial setup.
You should actually flash system-part1 to allow for a separate application module.

This posts shows how to update manually and after that you should also be able to have Workbench update your device as usual.


#3

Awesome thanks again. I reflashed to system-part1 will try VSCode tonight.


#4

Nope same issue with system-part1 flashed. Build and download in VSCode and stuck with yellow.

Flash system-part1 again and reset all good but no sketch ofc.


#5

Does this also happen when you power the device with a phone charger?