Verbose local compile


searching the forum got me to this post:

Which says I should be able to add “particle.enableVerboseLocalCompilerLogging”: true
to settings.json. But when I do, I get an error:

Any hints much appreciated.


ping @m_m

Does reloading the Window help?

I think it’s trying to tell you that you should open the g1_cellular project directly in Workbench, not the folder above it.


I’d not add this manually but use the respective settings screen
That helps avoiding typos and putting it in the wrong file.


hi @darrenji :wave:

VSCode’s settings are scoped - that is, individual settings can apply to the “user” (aka global) and the “workspace” (aka folder):

note: somewhat confusingly, when working within a multiroot workspace, there’s a third scope of “folder” which behaves like the “workspace” scope when working within a normal folder :thinking::man_shrugging:

your settings are typically stored as follows:

  1. user-level:

    • Windows -> %APPDATA%\Code\User\settings.json
    • macOS -> $HOME/Library/Application Support/Code/User/settings.json
    • Linux -> $HOME/.config/Code/User/settings.json
  2. workspace-level (when in a normal folder):

    • Windows / macOS / Linux -> <your project's folder>/.vscode/settings.json
  3. workspace-level (when in a multiroot workspace);

    • Windows / macOS / Linux -> <your-project>.code-workspace (located wherever you placed it upon creation)
  4. folder-level (when in a multiroot workspace):

    • Windows / macOS / Linux -> <your project's folder>/.vscode/settings.json (same as item 2 above)

in this specific case, "particle.enableVerboseLocalCompilerLogging": true is scoped to the “user” - that is, it applies to all workspaces and folders. as @ScruffR notes, it’s often easier to use the built-in settings editor: from VSCode’s main menu on Windows or Linux, click: “File” > “Preferences” > “Settings” (windows). on macOS, click: “Code” > “Preferences” > “Settings”.

EDIT: bah! sorry, i got that wrong :man_facepalming: - "particle.enableVerboseLocalCompilerLogging": true is internally scoped to window which means it applies to workspace / folder but can also be applied globally (aka “user”). i think @nrobinson2000’s suggestion is closer to the mark - are you working within a mutliroot workspace? what does the workspace section of the audit report generated via Particle: Audit Environment show?

hope it helps :+1:


pro-tip: with VSCode’s settings editor open, you can easily flip to the JSON file where your setting is stored by clicking the {} icon at the top-right of the pane.

for example, you can toggle the scope to “user” then click the {} icon / button top-right, and you’ll be taken to your user level settings.json file.

this can be handy sometimes to for example avoid scrolling through the giant list of settings when you simply want to remove something entirely.