Compile never finishes

I had successfully used the Web IDE to flash my Particle Boron with some code that does GPS stuff. All was well. However, I wanted to get debugging features, so I’m trying to use the Particle Workbench in VS Code. I downloaded the installer and followed the steps. I made a new project with the “Create a Project” button and used the “Configure Project for Device” command to set my OS version (1.4.4) and device type (Boron) and put in my devices ID.

I tried to compile locally and this is all that will happen in the terminal:

> Executing task: make -f 'C:\Users\phil\.particle\toolchains\buildscripts\1.9.2\Makefile' compile-user -s <


:::: COMPILING APPLICATION

Creating c:/Repos/Particle/gps-tracker/target/1.4.4/boron/platform_user_ram.ld ...

It will create the platform_user_ram.ld file and put this in it (or add another line with the same thing if I try a second time):

_user_part_static_ram_size = 89K;

It just freezes here forever though. I still have a spinner in the VS Code footer that says “Building…”, but nothing happens. I’ve waited like 15+ minutes: nothing.

I tried flashing locally (which in hindsight was a terrible idea) and it put the device in DFU mode successfully, but then gets stuck exactly like the compile command. Now I can’t cloud flash the device with the Web IDE anymore either because it says the device is offline.

If it’s relevant, the code I’m trying to flash is just the default .ino file with nothing but an empty setup and loop function.

Any ideas of other things to try?

After I posted this, it finished flashing… It took maybe 35 minutes or so… After about 15 minutes of nothing happening, I didn’t believe it was really doing anything anymore. It flashes faster now when I do it again (43 seconds now, much more reasonable). I guess if anyone comes across this in the future, try giving it a nice long time before assuming it is never going to happen.

It took maybe 35 minutes or so

ah, jeeze :man_facepalming: it’s admittedly a bit slow over on windows but i see about half that on a fresh build typically.

it might help to enable verbose logging on the local compiler - at least then you’ll have a clearer visual cue that it’s actually doing work still. see “Enable Verbose Local Compiler Logging” over here:

https://docs.particle.io/tutorials/developer-tools/workbench/#settings

also, if you haven’t already seen them, we have a bunch of docs and walk-thru videos:

https://docs.particle.io/workbench/

in particular, you might want to check out:

Getting Started with Particle Workbench:

Building Firmware Locally with Particle Workbench:

hope it helps :+1: