Local Flash and Debugger hang in Workbench (VS Code) Windows 10

boron
Tags: #<Tag:0x00007fe2207a08f0>

#1

Hi folks, installed Visual Studio Code and Workbench on Windows 10 64 bit and have a couple issues, hoping for help.

Dependencies are installed, code compiles fine with libraries, OTA flash to Boron works no problem. Worked through the whole workflow from Code -> Target -> Compile -> Flash, only encounter issues on last step with local flash and debugger.

Here’s what I get when executing the debugger (Boron in DFU mode with JTAG ribbon connected to debugger and it plugged in to USB, Boron also plugged in to USB):

Executing task: make -f ‘C:\Users\user.particle\toolchains\buildscripts\1.5.1\Makefile’ flash-debug -s <

It just hangs. Same behavior for Local Flash.

Occasionally get this message:

src/control/storage.cpp:63:50: note: #pragma message: External flash is not supported
#pragma message(“External flash is not supported”)

Ideas?


Verbose local compile
#2

hi @RobotChicken :wave:

the message you shared there is what you’ll always see when first running a local compilation step. compilation tasks take a bit to complete so it’s entirely possible that it’s not hung.

one thing you can try: enable verbose logging. open your project’s ./.vscode/settings.json file and add this line:

"particle.enableVerboseLocalCompilerLogging": true

with that in place, go ahead and run a few local compilation tasks - you should see logs output below the message you shared - then share any errors that pop up.

also, fwiw, VSCode puts a “building” icon (hammer & wrench) in the status bar bottom-left. you can click that icon and it will list which tasks are currently running.


#3

Hi @m_m,

Thanks for taking the time.

Two things to report. After adding the verbose entry I could see lots of building happening. It took about 16 minutes to build and flash the application successfully. However, it failed to contact an openOCD server due to timeout which I assumed had to do with the two Windows Firewall prompts that popped up (openocd.exe and Visual Studio Code). I accepted them both, cleaned the make directories, and tried again.

Unfortunately, the second time I got the Visual Studio Code Error again: Failed to launch OpenOCD GDB Server: Timeout, and no firewall prompts. It gave me the option to open launch.JSON or cancel. Following the steps in the tutorial I would expect to be able to open the debug console at this point and start debugging, but can’t because I assume openOCD failed to run. Do I have to install openOCD separately, or is it somehow included in the Workbench extension dependencies?

I am 8 minutes into running it again with a local flash to confirm that piece works for me. Would very much like debugging to work as that is a huge incentive to use VS for continued development.

Thanks again for your help.

-RC


#4

@RobotChicken ah, sounds like you’ve run into:

sorry about that - i’m working on a fix as we speak but it’s proving surprisingly hard to sort out for a lot on non-code related reasons :grimacing:


#5

In that case I’ve gotten as far as I can for tonight! So long, and thanks for all the fish.

Edit: did the workaround above and was able to use the debugger!


#6

@m_m, any luck working out this issue? I haven’t updated Cortex Debug since reverting it cause I don’t want to break anything.

-RC


#7

yep, you should be good to go now: