Using Webhooks in IFTTT to call a function on Particle photon board

Because IFTTT is disconnecting Particle, I have to start using Webhooks to integrate between IFTTT and Particle. All of my particle commands are call a function. I have been through the help articles and altered various parameters in the Webhooks filelds, but just not having any luck.
Getting error “Action failure message: Your server returned a 400. Unable to make web request to
Webhooks settings as per photo attached FYI. Can anybody help?

Your device belongs to product so maybe this is the case.
Try this URL:

and please do not duplicate the topic :pray:

Make sure that your deviceId is correct and access token
the product no: I got from previous Topic where IMHO we should continue T/S.


Hi there. Thanks for the update, however that adjustment didn’t work. Looking at previous posts I used this instead and hey presto, it worked! No idea why I had to use these codes in the Webhooks fields though??

1 Like

Not sure either :man_shrugging:t3: I’m not using webhooks at all. But glad that it’s working :+1:

Ha haa - this is literally nothing like the instruction, nice work for finding out how to make it work :slight_smile: - so you moved the API token up into the URL - left headers empty,.,
Which post did you refer to as I am having the same trouble and would rather not duplicate if someone else has had the issue already.

Hi Joe

Copied this post IFTTT going away, need some pointers - #12 by codev3rt from codev3rt on Jun 6

Hope that helps

Thank you - finally got it working - it turned out my issue was with IFTTT - where I deleted the existing Particle Function and tried to replace with Webhooks it wouldn’t let me save it - instead giving an error message. I created the Applet from scratch with google Assistant V2 > Webhooks using the original migration instruction and all now working.