Using Device Doctor with Photon: Command failed: dfu-util... etcetera

I tried to run Particle doctor because I have a Photon that obviously is in an unhealthy state. I have put the device in DFU mode and after selecting “continue” the system responds:

“An error occurred while attempting to update the system firmware of your device:
Error: Command failed: dfu-util -d 2b04:d006 -a 0 -s 0x080A0000:131072 -U user_firmware_backup.bin
File exists: Cannot open file user_firmware_backup.bin for writing”

…and that the advice to visit the community for help with this error.
Can anybody help me???

Could you try updating the CLI to the latest version and giving it another shot?
Posting a Screenshot of the entire command sequence would be helpful to see how you got there.
Particle update and Particle flash --usb tinker usually take care of most issues as well, if you want to give those a shot.

What OS are you running on your computer?
Can you try a different USB cable and port?

When using the command @Moors7 suggested above, you should add the verbose switch -v to get more elaborate output.
e.g.

particle flash --usb tinker -v
1 Like

Here is the screenshot that you requested. I am using Windows 10 *home); I have tried other USB cables but with no effect.
I have tried over and over again, and at last succeeded in getting this photon to work; so that one is solved.
However, I have two other Photons that show the same issue.
What is worth to notice is that all three Photons -when powering up- are blink green (which is normal), next they are blinking cyan (which is also correct), but then start blinking cyan very “aggressively” (blinking fast) resulting eventually into a short red flash, after which the fast cyan blinking + red flash is repeated.

Again: I managed to "resurrect"one of the Photons, by repeatedly using the Reset and Setup buttons, but with no succes with the other two.

The only difference from the first one to the latter two is that thefirst one was still claimed to my account and the others were removed in one of my previous attempts to re-activate them.

The rapid flashing is normal and indicates the cloud handshake, but the red flash suggests a keys issue which I usually don’t tackle with particle doctor but rather with

particle keys doctor <yourDeviceID>
particle keys server

(all in DFU Mode)

Hi ScruffR,
Thank you for the quick response.
For both Photons: according to the yellow blinking, they should be in DFU mode; however particle keys doctor responds that the device should be in DFU. So obviously it is not recognised as DFU mode???
Particle keys server requests “a server key in DER format”. What is that?
Again, as I wrote before: could be that the devices are not longer recognised as devices that are on my account: I tried to setup a few times using my iPhone and then the process got stuck in the last part of the procedure.

Hi forum, I’ve also got this problem - exactly the same as @Jan_dM , I’ve tried tinker and DFU. The device (a photon) flashes yellow but I can’t get the CLI to see it, no matter what mode. CLI is latest version - leads, USB port etc… all tested using other devices - all OK

Little update: I found a dodgy GND wire on the power supply I was using to supply the Photon that crashed, which affected a known good (2nd) photon (but luckily didn’t crash it) - the lead caused extended green transition to cyan flashing - short breath cyan cycle - then back to green. Remove the (good ) photon from circuit and power from a USB port and no problem - hooked onto the cloud within seconds. So I suspect this bad GND somehow caused the the keys to be corrupted in the Photon I’m having trouble with. Does’t fix the DFU not being seen issue - but it may offer some insight into the original cause.