USB Driver Strangeness [SOLVED]

I think there is a fundamental problem with the USB driver under Windows 7. Whenever a USB session connection is broken, such as when loading revised firmware to the core, the USB connection can’t be reestablished without a reboot or by disabling then re-enabling the port. This, of course, makes for a pretty painful development cycle. Any suggestions will be gratefully received.

I’m adding this issue here since the related problem (out of control cursor) was marked as solved.

captnkrunch, I run on Win 7x32 and the only thing that drops out is the COM port connection. So I have to close Putty before I reboot the Core or do an update otherwise the COM port doesn’t come up correctly. When I do that, I have no problems.


Thank you. starting from a cold boot your suggestion certainly helps most of the time but when do you start puTTY? if after the code starts executing, won’t some of the early stuff will be lost ? This still seems unstable to me.

You can use code to wait for any keys to be pressed before continuing to run the code

while(!Serial.available()) SPARK_WLAN_Loop(); // PRESS ENTER TO CONTINUE

Good tip. Thanks. but since I no longer trust the USB driver, I elected to just use a delay(35000) which seems to keep me out of trouble most of the time. Looping on the SPARK_WLAN_Loop(); would probably be a better idea.

1 Like

delay() calls SPARK_WLAN_Loop() so no need to call it yourself!

Which USB driver are you refering to? The built-in one in Win7?

1 Like

Apparently it is a microsoft driver. I have attempted to install the core usb driver on several occasions but it is eventually replaced by the microsoft version. I do not know why and I certainly don’t know how. I have attempted dbub’s driver installation instructions but they only seem to work temporarily (maybe between reboots?).

Strangely, right now, I have two cores … one loads the wrong usb driver and the other won’t load any usb driver at all. Very frustrating. I’ll gladly accept any advice, constructive or not.

I am hoping @BDub will see this and comment. He has the most experience in this area.

I cleared out both cores and started over. Both work now but in the process I briefly observed the red flash of dementia and some other wonderful colors. I still believe there are fundamental issues either in the USB driver (most likely) or on the core side of the USB interface.

Yesterday I elected to run my program (basically Serial Test) all nite but without puTTY. This morning initiating puTTY shows no output although I’m confident the program is still running. My trick of disabling and enabling the driver has no effect. However unplugging the core’s USB connection(powering down) then replugging (ie, resetting) does display serial via puTTY.