Unable to setup Argon via WiFi

I made a purchase of 5 mesh boards last year, and recently heard the news that mesh has been discontinued. I never was successful in using my Argon or 4 Xenons in the way that I wanted (sensors for home IoT use), so they have been sitting in my workbench since the day I initially set them up.

I pulled out the Argon to repurpose it and use it to replace a Photon in a project. It connected to my iPhone via Bluetooth and downloaded a software update. I elected to not use mesh (obviously).

However, the device setup failed after I entered my Wifi password, with the last successful step saying “connecting to the internet via Wi-Fi - starting a secure session with the Particle Device Cloud.” The error says “Your device failed to obtain an IP address. Please make sure your device has internet access.”

For the sake of troubleshooting, I tried connecting to a neighbor’s unsecure network and had the identical result. I wasn’t surprised though as I have no unusual VPN or firewall settings that have posed a problem before. I was also successful in connecting a Xenon using an ethernet shield from the same network, so it doesn’t appear to be any part of the connection between my router and the Particle servers.

It’s been a year so I’m not positive, but I think when I first set up the Argon I used the ethernet shield, so it’s possible my device has a defective Wi-fi radio and/or antenna that I wouldn’t have known about at the time.

I’ve tried many hard resets, along with resets of the router and the cable modem. I also tried setting the device up next to the router and have removed and reconnected the Wi-fi antenna to ensure it’s solidly connected. I’ve used three different 5v USB power supplies (one of which can supply 3A) and two different cables to ensure it’s not a power supply issue.

I’ve been a very pleased Particle customer for a long time… but I’d be lying if I said this wasn’t very frustrating, especially on the heels of the news of the discontinuation of the Mesh program. I pulled this out of the box hoping to salvage at least part of my investment in the platform only to not even be able to get it connected.

Edit: I’ve made further attempts to troubleshoot with the particle-cli interface. When I load the particle doctor tool and attempt to run it, after placing the Argon in DFU mode, I get this error:

The Doctor didn't complete successfully. "path" is not defined: undefined

Another error I got:

The Doctor didn't complete successfully. Error writing firmware: file does not exist and no known app found.

I continued working on this, using particle-cli to update the firmware to 1.4.4.

I tried to take the device out of DFU mode, and now it’s completely unresponsive. Neither the mode nor the reset button elicit any response. The device appears to be completely dead. I didn’t do anything that should have shorted any pins out or caused any physical damage.

I never was able to get it working. Particle is replacing the device.