Unable to install CLI - SSL cert problem

My VSCode started complaining about the CLI not being executable. When I run Particle from the command line I get a segmentation fault. I thought to try a new install of the CLI as directed on this page:

However, when I run the command line to install the CLI it fails silently.

Removing the "s" from the CURL options I get:

bash <( curl -L https://particle.io/install-cli )

curl: (60) SSL certificate problem: unable to get local issuer certificate

I'm running OSX 14.5

Previous articles suggested corporate firewall issues but I'm on a home network.

I overcame this problem by adding k to the CURL options. However, that is less secure. Would Particle provide the hash for the CLI so we can verify that we got the right stuff?

There is something odd with the certificate chain on your computer, but it's not clear what. In any case:

% curl -L https://particle.io/install-cli > install.bash
% shasum -a 256 install.bash 
c1b677286352dc83906afeddb2a2ecaa13ac675cf52bb97d01fdb914d9bf8c73  install.bash

I had to add the -k option to the curl command. Then it worked and I get the same hash.

Thanks.