Particle CLI Installer (Win10) - Installation Aborted for OpenSSL

I have installed the Particle CLI Installer on 2 different Win10-64bit computers, and both have the same issue.
The install goes along just fine, but when it shows “Downloading Open SSL”, it then changes to:

Installation Aborted
Setup was not completed successfully.

Any ideas why this might be happening ?

Silly question but are you connected to the internet when you are installing? You could try downloading and installing OpenSSL manually.

Yes, I am online, that is how it was able to download everything before it got to the SSL part.

@harrisonhjones, I see the same issue on a Windows 8.1Pro 64bit.
It seems as if the download fails (e.g. due to unresolvable URL maybe?)

@mikemoy, to finish the installation without OpenSSL, just restart the installer and untick the OpenSSL option and then manually download OpenSSL as Harrison suggested.

I’ve filed this issue for it

Thank you both. I hope I am not going to make a fool out of myself by asking this next question.
When you go to this web page:

You will see there is a clickable link called “Windows CLI Installer”. When you click on it, it downloads a file named. “ParticleCLISetup.exe”

My question is, since there is no version number in it’s name, how do we know when it’s been changed ?

@mikemoy, with the Windows installer, the CLI will update itself to the latest version when you run it. You can also force an update check with particle update-cli. :wink:


That will teach me to rely on a download link on a 3rd party host. I’ll copy the OpenSSL setup file to a Particle server and update the installer.


I uploaded a new CLI installer. There was a security advisory for OpenSSL on Thursday so I updated that dependency to the latest version.

Note: If you downloaded the CLI installer in the last day it it may take up to 24 hours for the Cloudfront server cache to get a new version (not in your browser, clearing your cache doesn’t help).

1 Like

I just tried to download the installer this morning and I am having the same issue as the OP. The installer aborts at the openSSL point.

Julien, is it possible to tell if you have the latest installer somehow?

The latest ParticleCLISetup.exe is 5,992,448 bytes.

1 Like

The version that I can get from is 5,992,456 bytes. Am I getting this from the incorrect location?

Mod edit (@harrisonhjones): Adding ping: @jvanier

I’m not sure what else to tell you.

Here’s what I’m getting when I try to download the file through the cURL tool. It shows Content-Length: 5992448.

$ curl -v -o ParticleCLISetup.exe
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0*   Trying
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0* Connected to ( port 443 (#0)
* found 173 certificates in /etc/ssl/certs/ca-certificates.crt
* found 697 certificates in /etc/ssl/certs
* ALPN, offering http/1.1
* SSL connection using TLS1.2 / ECDHE_RSA_AES_128_GCM_SHA256
* 	 server certificate verification OK
* 	 server certificate status verification SKIPPED
* 	 common name: * (matched)
* 	 server certificate expiration date OK
* 	 server certificate activation date OK
* 	 certificate public key: RSA
* 	 certificate version: #3
* 	 subject: CN=*
* 	 start date: Fri, 29 Apr 2016 00:00:00 GMT
* 	 expire date: Mon, 29 May 2017 12:00:00 GMT
* 	 issuer: C=US,O=Amazon,OU=Server CA 1B,CN=Amazon
* 	 compression: NULL
* ALPN, server accepted to use http/1.1
> GET /cli/installer/windows/ParticleCLISetup.exe HTTP/1.1
> Host:
> User-Agent: curl/7.50.1
> Accept: */*
< HTTP/1.1 200 OK
< Content-Type: application/octet-stream
< Content-Length: 5992448
< Connection: keep-alive
< Date: Thu, 02 Feb 2017 21:59:54 GMT
< Last-Modified: Sat, 28 Jan 2017 21:32:48 GMT
< ETag: "2e349f672a5926726c48d8f9010d8a68"
< Accept-Ranges: bytes
< Server: AmazonS3
< Age: 32
< X-Cache: Hit from cloudfront
< Via: 1.1 (CloudFront)
< X-Amz-Cf-Id: sRE2xoM-lQs6mhGWarwoYJv2CC0560SgdkLIZH12ig_izV0U0iYfkw==

Maybe try the S3 link directly?

@jvanier, the S3 link worked. I just double checked that the link I posted still had the incorrect file size and stalled at the same location. Then I downloaded from the link you posted and the file size was correct and the installation completed successfully.


1 Like