Umlaut ü makes troubles in webhook


#1

Hi, I’m programming a webhook to fill in data in a php generated webform. So far it works. The fields “user” and “uebezeit_h” are transferred correctly via POST and I get the expected return from the webhook.

E.g. for the user “f” I get the code of the success php page back which contains something like: “…Minuten eingetragen. Bis morgen, f !”
(printet via Serial.println(responsefromWebhook) from the photon)

I have Troubles with a username that contains the letter “ü”. In the former webform (which was not HTTPS and I could POST to directly from the photon) I had to replace the ü with “%FC” to make it work.

The reply I get for the user “Bogenschütze” (does not matter if put “Bogenschütze” or “Bogensch%FCtze” is: "…Minuten eingetragen. Bis morgen, Bogensch !"
So from the where the ü should appear there the username is not further printed.

Could it be that everything is properly working but the reply from the webhook gets “processed” and the ü or %FC is filtered out? Do I have to code the “ü” differently?

Any ideas how I could further investigate this?


#2

Have you tried \xFC?

I’d have to try, but this would be the first thing I’d check.


#3

I checked now, so far same result.


#4

btw, I checked what the web form sends when typing in “Bogenschütze” with a sniffer and that was “Bogensch%FCtze”.


#5

What is the target server?


#6

do you mean the webadresse? that is www.musicteacher.de


#7

I believe you’re going to run into a problem because the webhook sends the data as UTF-8. If you were previously able to send the ü as 0xFC, your web form is expecting ISO-8859-1.

There is no way to change the character encoding of the data sent by a webhook, unfortunately.


#8

@rickkas7, that sounds logical. The good thing is that with this hint I can avoid hours of fiddling around and just conclude that without changes on server side I can not solve it.
I asked the system administrator of the site to change the specific username and avoid the “ü”. So now it should work.