Trying to connect to NB-IoT Spain network with Boron

Hi all,

I’m trying to connect Boron to Internet trough 3rd party NB-IoT nano SIM Card. The NB-IoT operator is Vodafone.

Previously I got connection using ublox SARA N211, with these AT commands:

AT+CEREG=2
AT+CSCON=1
AT+CFUN=1
AT+CIMI
AT+CGDCONT=0,“IP”,""
AT+COPS=1,2,“21401”

I’m not be able to connect Boron to Internet. So, I have a few questions:

  1. Someone has tried to connect Boron to NB-IoT network?

  2. When will Cellular.command() be ready to use? This is very necessary in order to send AT commands directly to ublox module.

  3. I’m trying to implement NB-IoT connection on my own custom firmware (based on v0.8.0-rc.27). How can I run new AT commands like AT+COPS=1,2,“21401”?

  4. I saw a function called LOG. Is there any way to debug the execution of the application?

Thank you in advance,

Manuel Montenegro

1 Like

Is you Boron an LTE version (originally only recommended for US users)?


The 2G/3G version cannot be used for NB-IoT

Hi, ScruffR.

My board is Boron LTE.

Hi,

Any idea?

You could try running @rickkas7’s clouddebug code and post the output here

Thank you for the link. It works, but i need to try with my own custom device os version.

@rickkas7 could you please tell me how to enable usb serial logging in the latest device os release? I’m trying it by adding this in my application:

Serial1LogHandler logHandler(115200, LOG_LEVEL_ALL);

but it isn’t working.

Or could you share the source code for you build?

Thanks

Serial1LogHandler logs to the hardware TX pin, not the USB serial port.

If you use SerialLogHandler (not Serial1), then the USB serial port will be used, but you can’t get the detailed trace information for the cellular modem.

In order to get detailed trace information from the modem over USB serial you need to build a monolithic debug build, which can only be done with the gcc-arm toolchain or Particle Workbench.

Thank you.

Could you please give some key in order to build a monolithic debug?

I have installed Particle Workbench, and currently I’m modifying directly the device-os that I downloaded from Particle Workbench (I’m not sure if there are any better way), but this isn’t working (a lot of building errors like “this is not a git repository”).

Manuel Montenegro

If you are building the debug firmware in Workbench that will be monolithic.

I have followed the instructions from @rickkas7 (this post) and I managed to build a sample with debug using my custom connection.

This is the output I got:

0000005999 [ncp.at] TRACE: > AT+CGDCONT=1,“IP”,""
0000006040 [ncp.at] TRACE: < OK
0000006041 [ncp.at] TRACE: > AT+CEREG=2
0000006090 [ncp.at] TRACE: < OK
0000006091 [hal] TRACE: NCP connection state changed: 1
0000006093 [net.pppncp] TRACE: NCP event 2
0000006094 [net.pppncp] TRACE: State changed event: 1
> 0000006095 [ncp.at] TRACE: > AT+COPS=1,2,"21401"
0000006096 [hal] TRACE: PPP thread event LOWER_DOWN
> Serial connection closed. Attempting to reconnect…
Serial monitor opened successfully:
0000000404 [hal] TRACE: Cellullar Config – APN: USER: PASS:
0000000429 [hal] TRACE: Updated file: /sys/cellular_config.bin
0000000458 [system.nm] INFO: State changed: DISABLED -> IFACE_DOWN
0000000461 [system.nm] INFO: State changed: IFACE_DOWN -> IFACE_REQUEST_UP
0000000462 [hal] TRACE: PPP netif -> 8
0000000463 [net.ifapi] INFO: Netif pp3 state UP
> 0000000465 [system.nm] INFO: State changed: IFACE_REQUEST_UP -> IFACE_UP
0000001026 [sys.power] TRACE: Battery state CHARGED -> DISCONNECTED
> 0000002388 [hal] TRACE: Modem powered off
0000002388 [hal] TRACE: Powering modem on
0000002540 [hal] TRACE: Modem powered on

The modification of device-os I have done is this: from sara_ncp_client.cpp, function registerNet(), line 807 (release v0.8.0-rc.27) I have replaced

r = CHECK_PARSER(parser_.execCommand(3 * 60 * 1000, “AT+COPS=0”));

to

r = CHECK_PARSER(parser_.execCommand(3 * 60 * 1000, "AT+COPS=1,2,“21401"”));

NB-IoT vodafone Spain network doesn’t use apn, user and password and this is shown in the log. But later the serial connection resets, and we don’t know if this is a normal behaviour or not (we don’t have any other SIM card to try).

Apparently after a while, the network connection is up but then the modem power off and we don’t know why.

Any hints on that?

Thank @ScruffR and @rickkas7 for all your support.

Manuel Montenegro

Hi, I would like to know if it is possible to operate with Boron LTE in Spain. Regards

It is not possible to use the Boron LTE in LTE Cat NB1 (NB-IoT) mode. Only LTE Cat M1 is supported, and is only recommended in the United States, Canada, and Mexico using the built-in Particle SIM.