Troubleshooting Blue LED dim

I’m having the blue led dim and main led off issue.
Holding both buttons and then releasing reset while holding mode is not doing anything for me i have held it for 15-20 seconds ie doesn’t go into DFU mode /Factory reset mode

Are you using a core or photon and what were you doing that made it in that state?

Hi im using a spark core…
I was using it at a hackathon last weekend then tried to use it again yest and suddenly stopped working…

Can you remove it from any circuitry that it is connected to and perform a factory reset?

Right now its isolated only connected through battery bank or usb port.
Tried doing the factory reset. but no response from the board.

Can you plug it to your computer and try again?

Do not use the power bank for now in case there’s a power issue.

Plugged in laptop.
Held down both mode and reset button and then released reset.
Kept holding down the mode button.
no response from main led

just to be sure… You are hitting the correct buttons yeah?

Also, what happens if you don’t do anything when powering up? Is there anything indication on the LED?

Lol… thats a good question and for a second i was also stumped… but ya hitting the correct buttons…
and if i just plug it in the main led is off and the blue led is lit dimly

Hmm i’m not sure how you device went into that state so it looks like the firmware or even bootloader is not working somehow.

You might need a STlinkV2 to fix it or get a replacement as i cannot figure out what is wrong :wink:

Ya i know , i was wondering the same… and sadly i dont have the jtag equipment necessary for the flashing… so will try to get a replacement if possible…

Thanks for your help mate…

@zach Can you add some more info regarding the replacement?

@kmmonk or @kevin will take care of this instead

1 Like

Hi there,

I can definitely help with that. If you want to shoot an email to and reference this ticket, we can start that replacement process for you.