Photon D7 dim light

photon
Tags: #<Tag:0x00007fe2225c6be0>

#1

Hi guys

2 of my photons won’t start up, they just show a dim blue light on pin D7. Researching on the web it appears to be that the photon is corrupted/fried, and this might be the case for one of them, because it was power up with a 9V battery before reading that the maximum input should be 5V.

The other one, just stopped working on the PCB and won’t start again, when power on, just shows dim blue light.

When pressing the setup and reset button together, on one, there ir is a spark on the status light but nothing happens. On the other one, nothing happens.

Anyone got a fix for them or are they just doom? Is there any way to assure they are broken?

device 1

Device 2

Thank you guys.

edit: The one with the spark on the status led, after a while plugged, tried again the reset+setup button and now it display magenta, but I can’t get it to flash any code or to appear on my laptops serial port.


#2

Dry DFU mode and Particle update


#3

Hi
Once in DFU mode, I can’t put it on “listening mode”, it just stay blinking yellow.


#4

That’s not what @Mjones suggested, he meant you should then (in DFU Mode) run the CLI command particle update

I’d go further an do this

particle flash --usb tinker -v
particle update -v
particle flash --usb tinker -v

(all in DFU Mode - if the device falls out of DFU Mode, reengage)


#5

Hi @ScruffR, once again thank you for being so helpful, the instructions that you give worked. I never had to use DFU mode or knew how to use it.

One of the 2 photons was repair(the one which I manage to put on DFU mode) the other one, I can’t take te blue dim light on D7. Or see any spark on the status led. Is any repair utility or status checker via CLI to know if it is possible to repair or is doom?

Thank you, again. and @Mjones


#6

You can try this approach for your other device


#7

Thank you.