Trouble getting GPS data from ultimate gps module GPS on my own PCB

I am using a Boron microcontroller in order to get GPS data from the adafruit ultimate GPS module. This worked out great when I had the featherwing attached. I eventually spun up a PCB with the parts and now I cannot get a signal back from the ultimate GPS module, was hoping I could get some assistance.

the above image shows my shematic for the GPS module. You can find the datasheet here:

I can confirm that the VCC is getting 1.8 volts, GND is connected and the GPS_RX line (from the BRN_TX) is getting a message in order to request GPS data, but nothing happens.

I set the /RESET line to be HIGH, CTS/RTS to just be set to inputs on the Boron (maybe this is the issue), and I set ON_OFF to be low. WAKEUP is also just an input.

Is there something special the adafruit ultimate gps featherwing does for communication purposes? do I need to use flow control w/ RTS/CTS?

Here is my relevant code snippets:

int GPS_NOT_EN = A0;
int GPS_RESET = A3;
int GPS_CTS = A4;
int GPS_RTS = A2;


digitalWrite(GPS_NOT_EN, LOW);
digitalWrite(GPS_RESET, HIGH);
digitalWrite(GPS_CTS, HIGH);
digitalWrite(GPS_RTS, HIGH);

Adafruit_GPS GPS(&GPSSerial);


// in tight loop
char c =;
Serial.print(c);  //nothing prints

@krixen1 since the unit operates at 1.8v you will need a level shifter to get the 3.3v logic level needed by the Boron. That's what the featherwing have that you didn't implement.

Can the GPS module accept 3.3V logic levels? I see no data coming back from the GPS module to the Boron, that line is completely flat.

Are you using the exact same GPS module as adafruit module?

I’m not sure what’s wrong with what you have. I typically prototype with featherWings from Adafruit but then use their Eagle cad files to create the identical circuitry using the same GPIO pins. That way once I get the custom board it’s the same firmware and libraries. For reference, here is the Eagle cad files for the Adafruit Ultimate GPS featherWing: Downloads | Adafruit Ultimate GPS featherwing | Adafruit Learning System

1 Like

@jgskarda, you bought the 1.8v capable version of the module, the Wurth 2613011037000 instead of the 3.3v one, the Wurth 2614011037000. The one you have is NOT compatible with 3.3v and you would need 1.8v-to-3.3v level shifters between it and the Boron for it to work.

The unit used by Adafruit in their latest Ultimate GPS board is made by GlobalTop. The Wurth unit has a different pinout and has no castellated edge connections (it is SMD only). So I hate to say it but you are not even close!

1 Like

I didn’t dig through the details like you @peekay123 but that’s what I figured @krixen1 issue was. This is precisely why I always use the Adafruit open source Eagle cad files. I can just copy/paste into my own Eagle files and not mess up on part numbers like this. :+1:

1 Like

@jgskarda, totally agree and I often get inspiration from their hardware design so I always look at the schematics.

@krixen1, you may want to look at a 3.3v module or look at Texas Instruments (and others) for single or multi-bit unidirectional level shifters like the 4-bit TXU0304.

1 Like

I worked with all featherwings and someone im working with made the PCB board. He is away for a week so I won't be able to talk to him about what is going on here, but I do see that it's a different GPS module, maybe there was a reason why that was chosen instead.

I was also told that this schematic i have is outdated and there is voltage conversions on the new one but my board I have might be damaged. the plot thickens!

Thank you for all the help!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.