Tinker iOS app won't build - "tinker_pin_data.json: No such file" [Solved]


#1

Trying to build the Tinker app in Xcode following the instructions.

I get 1 build error:
/photon-tinker-ios/shared-assets-mobile/device_pin_info/tinker_pin_data.json: No such file or directory

I can see the filename in red under “SharedAssets”. I’m not sure how to go about to build or create this file? Any suggestions? If I copy the file from the repo into the location I get a different error that multiple commands are trying to produce it.


#2

@jensck_particle Any ideas to help the Tinker iOS app build? I tried a different computer should it be an environmental issue but it gets down to the same issue.


#3

Sorry to hear you’re having trouble, but I only work on Android. For iOS questions you’ll want to talk to @Raimis!

@Raimis, can you help him out here?


#4

@Raimis Besides the problem on tinker_pin_data.json during the build, the other issue is we may need instructions for Stripe.

I took me some time to strip out the tinker pins to make that build error go away, but after that, the other issue seems to be Stripe.


#5

Hello @bloukingfisher sorry to hear you are having trouble getting the app to build. As for tinker_pin_data.json - you need to update git submodules by running git submodule update --init. That file lives in different repository which will hold all the definitions shared between ios and android apps. It is included in tinker app as submodule.

As for stripe you need to obtain stripe key that you need to define as let stripeKey in Keys.swift. I see that this variable is missing in keys template that comes with an app (will be there with next merge to master). Not sure how stripe will fail if you will only define that variable with random string for the value (this will eliminate build error), but you can try that before obtaining the real key.

Please let me know if you will be able to build an app with this information.


#6

Thank you @Raimis ! Yes, now it builds. I think it would be helpful to include something in the instructions about the submodule in a future update.


#7

Glad to hear that it helped. Documentation unfortunately lags behind the development and this was a very recent change in our flow.