What is "core pin Unknown error:404" [SOLVED]

when i use the spark app and try to use one of the pins as digital read i get : What is “core pin Unknown error:404”

This error happens when your Core no longer has the Tinker firmware installed. You can “Re-flash Tinker” from within the app. In the iOS app, it’s in the Cores menu on the left; in the Android app, it’s in the menu in the upper right corner of the screen.

I’ve been lost in a circle a few times with this, so hopefully this helps iOS users. I’m not sure if it’s a similar issue with Android.


Thank you very much for your help. This solved my problem and was very easy.

1 Like

Thanks for your post!!

@zach Just got started with SparkCore, in the next version of iOS app, could you make it easier to find ‘RE-FLASH TINKER’ button. It helps newbies. Without @BDub post I would have lost my way.


That’s good feedback @Pravi, when we have an opportunity to do our next refactor of the mobile apps, I will definitely include that

Also created an issue for it in Github: https://github.com/spark/ios-app/issues/6

when I try to click the arrow, the iOS app crashes. every single time :frowning:

Same thing happens to me. I have to reset the core and connect it to the network again and it will work. However; when I try and use Blynk with it I’ll get the same error and have to start over again. (Worked great the first couple times and now it’s stopped.)

As soon as you flash something, the Tinker firmware gets overwritten. That means you can no longer use the Tinker app the way you have. You can either flash Tinker again (which is what happens with a factory reset), or implement the tinker functions in your own application.