The system firmware upgrade seems to make the Electron breakdown

I ran a ‘particle doctor’ command before reusing a long unused electron.
But after the system firmware was upgraded, I couldn’t make it to enter DFU mode again.

My host doesn’t recognize it connected via usb
and the LED under the battery connector is blinking red and the D7 LED is blue.
Also, the strange thing was that there was no problem with the other two computers.

Why such a problem occurs?
How can I fix it?

I understand that you are experiencing issues with connecting to or viewing your Serial port output.

An immediate check, if you have not already done so, is to try connecting the device to another computer and if the device can be detected.

If this does not work or if you like to know more, you can read more about Serial port connection for various OS here:

For Mac, to locate your serial port, you can also try ls /dev/tty.*

Are you using Windows 64 bit? We regret to inform that there are no 64 bit drivers for Windows 7. Serial connection is not possible.

If you are on other versions of Windows, please check the below guides:

1 Like

@particle7888, this seems to be a case of the dim-blue-D7 bug.

1 Like

Thank you @ScruffR! :slight_smile: I did not propose that because I felt that the user can first check on why the device cannot be detected in USB. The USB fix for DIM D7 requires that the device can be detected.

I am including the DIM D7 solution:

The dimly lit D7 LED is a likely sign that the Electron’s bootloader is corrupt. We’ll replace the unit for you (if the device is within our 6 warranty period), but you can correct it yourself if you so wish.

Have you tried our browser-based device restore tools?

Via USB:


If the above does not work, please try using this inexpensive ST-LINK/V2 Mini SWD USB stick - about US$15 from Amazon but available elsewhere as well. That combined with our JTAG programming instructions should allow you to reprogram the bootloader on the device and usually get it working again.


Thanks very much for the detailed explanation.

I’ll try the solution you gave me.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.