Sparkcore lost connection after some time connected

Hi,

I have some problems with my Sparkcore connection, after some time connected at my wi-fi the cyan light begin blink and the hardware lose the connection, when I make a restart it connect again and begin to work perfectly.

Anyone have a similar problem?

Thanks,

Hi @marciocamurati, we call that the “Cyan Flash of Death.” It’s a difficult bug to squash, but we’re working hard on it with lots of help from the community. If you compile the latest code in the web IDE and flash it to your Core, it will at least recover on its own without you having to hit the reset button.

The main discussion thread is here:

It sounds like you are suffering from this bug:

There is intensive work underway to identify and eradicate the root cause; meanwhile there is a workaround that may be useful to you in that thread.

1 Like

Hello everyone, is there yet a solution to this problem? I have 4 spark cores here now in test and I loose connection with them very often. Cloud connection disappears even more. I just put the SSID in it and get the value published in a variable. So my application is very small.
Can you please inform us about your status, because with the spark working like this it is close to useless.

@GrtVHecke,

are your cores white?

Have you tried doing a CC3000 patch?

Kennethlimcp, can you please tell me how I can do the CC3000 path?

Using DFU-util

  1. Install DFU-util (https://community.spark.io/t/tutorial-installing-dfu-driver-on-windows/3518)

  2. Download the CC3000 Patch (https://github.com/spark/cc3000-patch-programmer/blob/nobuttons/build/cc3000-patch-programmer.bin)

  3. Run the following command in CMD:

dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D cc3000-patch-programmer.bin

Using Spark-CLI

  1. Install Spark-CLI (https://community.spark.io/t/tutorial-spark-cli-on-windows-06-may-2014/3112)

  2. Run the command spark flash coreid cc3000

I will try this and keep you posted. How come this is needed since it are 4 fresh ordered (and this week delivered) Spark Cores?

You didn’t not answer the questions listed above and I had to suggest a solution based on my own guesswork :wink:

If your core is a black version, it already has the latest patch but sometimes re-patching works

Sorry for the delay, the problem persists, even after I flashed the CC3000 from the Spark commandline

Are all the 4 cores facing the same issue?