Spark Wifi credential

Hi guys,

I am not sure why this is happening but spark core is connecting automatically to two different networks without me having to provide it with SSID and password again. Its like the core is saving the WiFi credentials of the two different networks and connecting automatically.

Do you have any idea whats going on with the spark?

Muez

@Muez,

once you send Wifi Credentials to the core, it is stored in the CC3000 EEPROM for up to 7 profiles. :wink:

Do you know whether we’ll be able to ‘hard-link’ our Sparks to specific wifi networks in a future firmware? E.g. I only want it to work in 1 or 2 places and not let anyone else add extra networks.

So I guess this is 2 questions: will we be able to lock our Sparks to a small number of networks, and will we be able to lock our Sparks so nobody can take them and re-flash them out of our control?

  1. There’s no way additional Profiles can be added without them putting it in Listening mode. So you can configure the 2 Wifi profile beforehand and give it to them.

  2. You can modify the bootloader or firmware to prevent OTA or Listening mode but that doesn’t stop them from flashing over DFU :wink:

I have an issue on fresh firmware with connecting to Wifi. Older firmware worked fine on same board. Is firmware reset resets ALL wifi profiles or something additional is needed?

You can perform a factory reset, send in your Wifi credentials to see if it connects.

Did that multiple times already. Reflash CC3000 patch as well - no effect

To verify this is a firmware issue I’ve flashed back a backup copy of reset firmware back to core and it connected to WiFi successfully

I’m not really certain if I understood you clearly.

You flashed different user firmware OR you replaced the factory reset firmware?

Would also appreciate if you post all your issues/replies in one thread. So that we don’t have to read information everywhere :wink:

Both. I’ve replaced factory reset firmware so it would work with spark.cli
Spark.cli is not checking if core asks for security code therefore is not working with older cores.
Sequence:
0. Pre-condition: old reset firmware

  1. Flash something from WEB ide: WiFi setup & connection works after that
  2. Flash “spark flash … cc3000”: WiFi setup & connection works after that
  3. Factory reset: : WiFi setup & connection works after that
  4. Flash new factory reset firmware: : WiFi setup works, connection DOES NOT WORK
  5. Flash any new user firmware: WiFi setup works, connection DOES NOT WORK
  6. Flash cc3000 patch with dfu, run firmware reset: WiFi setup works, connection DOES NOT WORK
  7. Flash back reset firmware backup and reset: WiFi setup & connection works after that

i noticed mine doesn’t work from the cli wifi setup… but does with the phone app (found this out a few days ago)

Have you tried connecting with the phone app on the new reset firmware? if it works then maybe we need to look for a fix

1 Like

I think what you’re seeing there might be the cc3000 patch corrupting the saved wifi profiles… The factory reset causes those profiles to be erased, so they should work when you re-load the firmware. The ‘nobuttons’ branch, and the deep_update versions should either clear, or backup/restore the profiles after finishing the patch.

I’ll also add a bug to the spark-cli for that configuring wifi issue on older firmware:

Thanks!
David

I have recently used WiFi.setCredentials() and WiFi.clearCredentials() to great effect with over the air upgrade of WiFi credentials. My Spark Cores are being field trialled on a 6m mounting post 50m from the access point with a Cantenna. To save ‘going up the pole’ - quite literally - it has allowed me to change Wifi profiles to test out the best access point. To prevent unauthorised change of profiles I have included a password facility.

2 Likes