Spark Gets Local IP, Won't Connect

I’ve got the core with the chip antenna.

I was unable to claim the core using the android app (galaxy S3).

I sent the wifi credentials to the until using the USB cable and coolterm.

I know the unit is connecting, because I see a new device with a DHCP assigned IP address on my network that goes away if i unplug the spark.

However, the LED simply cycles from quick blue to quick red to quick faint red back to quick blue.

No green, no orange.

I was able to retrieve the CORE ID but cannot claim it via the website.

I cannot get the spark-cli to install.

Does anyone have any ideas? I had an idea for a project but this is making me feel like I’m over my head.

@phrasius, can you perform a factory reset, send wifi credentials via USB and observe the lights again?

when I do the reset the light goes back to the slow blue and I can connect via USB.

I can also send the wifi credentials from the android app but no matter how many times I reset and redo the credentials it goes back to fast blue/fast red.

I should add that I never get “white” LEDs. when I do the reset it alternates between fast red and fast magenta as long as I hold down mode, then goes back to the slow blue after I release the mode key.

@phrasius, that’s really strange. If you don’t mind, post a quick video or if this is too tedious, drop and arrange for a replacement!

@phrasius, that’s blinking cyan and not blue.

That’s clears the confusion now!!

The red/orange indication means that the core have bad keys. Unfortunately, we will require Spark-cli to continue on this matter.

Follow the tutorial here:

1 Like

Not so good with colors, I guess. :smile:

I did find both of those tutorials already.

I’ve tried both using solely 32-bit and 64-bit versions of OpenSSL and Nodejs. I’ve installed python 2.7.6 (both 32 and 64 bit). I’ve installed VS Studio 2013 express. I’ve made sure my everything is in my system path variable.

npm install -g serialport works.
npm install node-pre-gyp works.
npm install -g serialport@1.4.5 does not.

npm install -g spark-cli fails installing serialport 1.4.5.

Any ideas what I might be missing?

Can you try npm install -g serialport@1.4.5

C:\Program Files (x86)\nodejs>npm install -g serialport@1.4.5
C:\Users\Steve\AppData\Roaming\npm\serialportterm -> C:\Users\Steve\AppData\Roam
C:\Users\Steve\AppData\Roaming\npm\serialportlist -> C:\Users\Steve\AppData\Roam

> serialport@1.4.5 install C:\Users\Steve\AppData\Roaming\npm\node_modules\seria
> node-pre-gyp install --fallback-to-build

child_process: customFds option is deprecated, use stdio instead.

C:\Users\Steve\AppData\Roaming\npm\node_modules\serialport>node "C:\Program File
s (x86)\nodejs\node_modules\npm\bin\node-gyp-bin\\..\..\node_modules\node-gyp\bi
n\node-gyp.js" rebuild --name=serialport --configuration=Release --module_name=s
erialport --version=1.4.5 --major=1 --minor=4 --patch=5 --runtime=node --node_ab
i=node-v14 --platform=win32 --target_platform=win32 --arch=ia32 --target_arch=ia
32 --module_main=./serialport --host= -
rialport\v1.4.5\Release\node-v14-win32-ia32 --remote_path=./serialport/v1.4.5/Re
lease/ --package_name=node-v14-win32-ia32.tar.gz --staged_tarball=build\stage\se
rialport\v1.4.5\Release\node-v14-win32-ia32.tar.gz --hosted_path=https://node-se --hosted_tarball=https://no
child_process: customFds option is deprecated, use stdio instead.
Building the projects in this solution one at a time. To enable parallel build,
please add the "/m" switch.
..\src\win\enumser.cpp(443): warning C4996: 'GetVersionExA': was declared depre
cated [C:\Users\Steve\AppData\Roaming\npm\node_modules\serialport\build\serialp
          C:\Program Files (x86)\Windows Kits\8.1\Include\um\sysinfoapi.h(433)
  : see declaration of 'GetVersionExA'
..\src\serialport_win.cpp(254): error C2039: 'New' : is not a member of 'v8::St
ring' [C:\Users\Steve\AppData\Roaming\npm\node_modules\serialport\build\serialp
          C:\Users\Steve\.node-gyp\0.12.0\deps\v8\include\v8.h(1599) : see decl
  aration of 'v8::String'
..\src\serialport_win.cpp(254): error C3861: 'New': identifier not found [C:\Us
gyp ERR! build error
gyp ERR! stack Error: `C:\Program Files (x86)\MSBuild\12.0\bin\msbuild.exe` fail
ed with exit code: 1
gyp ERR! stack     at ChildProcess.onExit (C:\Program Files (x86)\nodejs\node_mo
gyp ERR! stack     at ChildProcess.emit (events.js:110:17)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (child_process.js:1067
gyp ERR! System Windows_NT 6.1.7601
gyp ERR! command "node" "C:\\Program Files (x86)\\nodejs\\node_modules\\npm\\nod
e_modules\\node-gyp\\bin\\node-gyp.js" "rebuild" "--name=serialport" "--configur
ation=Release" "--module_name=serialport" "--version=1.4.5" "--major=1" "--minor
=4" "--patch=5" "--runtime=node" "--node_abi=node-v14" "--platform=win32" "--tar
get_platform=win32" "--arch=ia32" "--target_arch=ia32" "--module_main=./serialpo
rt" "--host=" "--module_path=C:\\Users\
.5\\Release\\node-v14-win32-ia32" "--remote_path=./serialport/v1.4.5/Release/" "
--package_name=node-v14-win32-ia32.tar.gz" "--staged_tarball=build\\stage\\seria
lport\\v1.4.5\\Release\\node-v14-win32-ia32.tar.gz" "--hosted_path=https://node-" "--hosted_tarball=https:
gyp ERR! cwd C:\Users\Steve\AppData\Roaming\npm\node_modules\serialport
gyp ERR! node -v v0.12.0
gyp ERR! node-gyp -v v1.0.2
gyp ERR! not ok
node-pre-gyp ERR! build error
node-pre-gyp ERR! stack Error: Failed to execute 'node-gyp.cmd rebuild --name=se
rialport --configuration=Release --module_name=serialport --version=1.4.5 --majo
r=1 --minor=4 --patch=5 --runtime=node --node_abi=node-v14 --platform=win32 --ta
rget_platform=win32 --arch=ia32 --target_arch=ia32 --module_main=./serialport --
host= --module_path=C:\Users\Steve\AppD
-win32-ia32 --remote_path=./serialport/v1.4.5/Release/ --package_name=node-v14-w
in32-ia32.tar.gz --staged_tarball=build\stage\serialport\v1.4.5\Release\node-v14
-win32-ia32.tar.gz --hosted_path=
port/v1.4.5/Release/ --hosted_tarball=
erialport/v1.4.5/Release/node-v14-win32-ia32.tar.gz' (1)
node-pre-gyp ERR! stack     at ChildProcess.<anonymous> (C:\Users\Steve\AppData\
node-pre-gyp ERR! stack     at ChildProcess.emit (events.js:110:17)
node-pre-gyp ERR! stack     at maybeClose (child_process.js:1008:16)
node-pre-gyp ERR! stack     at Process.ChildProcess._handle.onexit (child_proces
node-pre-gyp ERR! System Windows_NT 6.1.7601
node-pre-gyp ERR! command "node" "C:\\Users\\Steve\\AppData\\Roaming\\npm\\node_
modules\\serialport\\node_modules\\node-pre-gyp\\bin\\node-pre-gyp" "install" "-
node-pre-gyp ERR! cwd C:\Users\Steve\AppData\Roaming\npm\node_modules\serialport

node-pre-gyp ERR! node -v v0.12.0
node-pre-gyp ERR! node-pre-gyp -v v0.5.19
node-pre-gyp ERR! not ok
Failed to execute 'node-gyp.cmd rebuild --name=serialport --configuration=Releas
e --module_name=serialport --version=1.4.5 --major=1 --minor=4 --patch=5 --runti
me=node --node_abi=node-v14 --platform=win32 --target_platform=win32 --arch=ia32
 --target_arch=ia32 --module_main=./serialport --host=https://node-serialport.s3 --module_path=C:\Users\Steve\AppData\Roaming\npm\node_modules\se
rialport\build\serialport\v1.4.5\Release\node-v14-win32-ia32 --remote_path=./ser
ialport/v1.4.5/Release/ --package_name=node-v14-win32-ia32.tar.gz --staged_tarba
ll=build\stage\serialport\v1.4.5\Release\node-v14-win32-ia32.tar.gz --hosted_pat
h= --hosted_t
14-win32-ia32.tar.gz' (1)
npm ERR! Windows_NT 6.1.7601
npm ERR! argv "C:\\Program Files (x86)\\nodejs\\\\node.exe" "C:\\Program Files (
x86)\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "install" "-g" "serialport@1.4
npm ERR! node v0.12.0
npm ERR! npm  v2.5.1

npm ERR! serialport@1.4.5 install: `node-pre-gyp install --fallback-to-build`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the serialport@1.4.5 install script 'node-pre-gyp install --f
npm ERR! This is most likely a problem with the serialport package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-pre-gyp install --fallback-to-build
npm ERR! You can get their info via:
npm ERR!     npm owner ls serialport
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     C:\Program Files (x86)\nodejs\npm-debug.log

C:\Program Files (x86)\nodejs>

Are you running command prompt As Administrator?

Yes. I’ve tried just running command prompt and running it as admin. I’ve tried the visual studio x86 command prompt. I’ve tried the visual studio x64 command prompt. I’ve tried making a shortcut to run npm.cmd and I’ve run that as administrator as well.



There’s limitations to what i can do over here cos we definitely need to install the tools and update the keys before moving further.

@harrisonhjones can you take over from here? :wink:

1 Like

Sorry for the delay. I’m traveling this week.

Assuming we don’t need the serial port module for key doctor then this is what you can do to just install the Spark CLI without the serial port module:

Do you have git on your computer? If not, we can either install git or just download the zip.

  • If you have git create a folder somewhere (call it “Spark-CLI”), go into it, and open up a terminal there. In the terminal enter the following command: git clone .
  • If you don’t have git and want to install it I would suggest you look here: When you are done do the above step
  • If you don’t have git and don’t want to install it go here: and click “Download zip” on the righthand side. Unzip that zip into the folder you create called “Spark-CLI”

Ok, now you should have all of the SparkCLI code inside a folder called “Spark-CLI” (or similar). You are almost done. Now follow these steps

  • navigate into the js folder
  • open/edit the file package.json and find the line “serialport”: “1.4.5”, remove it, and save the file
  • open a terminal window in the js folder and type sudo npm install -g. That should install the SparkCLI

Let me know if you run into any roadblocks.

Ok. I am able to get spark-cli installed from the git bash prompt.

Now, I cannot put the core into DFU mode. pressing both buttons and releasing the RST key gives me flashing red, not white.

I know I’m bad with colors, but that’s definitely not white.


1 Like

Here. Let’s try a different method:

With the core unplugged (it’s easier if the cable is plugged into the core and just unplugged from the computer) push and hold the MODE button down. With your friend hand plug the core’s USB cable into your computer. Keep holding the MODE button. If all goes well you should see flashing yellow.

Still flashing red.

I feel like that’s bad, right? :smile: