Spark-dallas-temperature library not compiling and cannot remove it

I am unable to get programs that have this library included to compile. I noticed this on Sunday, right after the library management system upgrade (may be related, may not).

I include OneWire as well. Error message is:

In file included from /src/aquabot_quad.cpp:2:0:

		lib/spark-dallas-temperature/src/spark-dallas-temperature.h:27:36: fatal error: ../OneWire/OneWire.h: No such file or directory
 #include "../OneWire/OneWire.h"

An additional vexing problem with the updated interface: I am unable to remove the library because the remove X button is covered/blocked by the message box that says: Remove spark-dallas-temperature from this app.

Please advise. Thank you.

2 Likes

That seems to be a similar issue as I had created with one of my libraries

Unfortunately, that lib is none of mine, so I won’t be able to fix it :wink:

Can I get a screenshot of the covered “X” button?

You can have a look at mine in this issue

I’m having the same problem. I posted this on another link.

2 Likes

Here is a screenshot exactly capturing the situation on FireFox. You can try to click the X, but it just doesn’t register.

Ok… so… there are TWO screen shots. heh. Thanks for looking into this.

Yes, regarding fixing libraries that aren’t ours, that leads us to trying to remove the library and just pasting in the content as a local library. Then we run into the wall of inability to click that X to remove. Computers… phooey

Just to clarify, this was working fine before the IDE update wasn’t it?

Yes, it was working fine before the update. Have used these two libraries (dallas temp and onewire) together for about a year. Thanks

I’m having the same problem :confused:

Is there any other options but copying all the files one-by-one to a new application ?

Any suggestion much appreciated.

~Michael

1 Like

Hi Michael. I just gave up and copied the code into my application, fixed the one little typo and moved on. I don’t know who can fix the problem. I don’t have access.

We are looking into taking over contributed libraries where contributors have stopped maintaining them.
This may also lead to deprecation of libraries if there are better alternatives to keep things tidy.
There are already multiple libraries for the DS18 sensors some better than others.

A temporary work around is to create a new project and use a previous version of the lib which hasn’t been auto-migrated to Libraries 2.0

1 Like

It would be a great, if others took over not maintained libraries, if changes in the Particle environment were needed.

I have several applications with this problem and +15 files in each, so I guess for now, it will takes some copy/paste work.

I think the real problem is that it is possible to lock the application by just adding a community library. If the remove button worked, the user would have several options for mitigating the problem. The root course is a simple error in the Web IDE. May bee it is easier for all, if Particle just fix the error ?

About the remove button I was able to have it show with FireFox and a small zoom factor or reduced font size, which allowed enough space for the remove button to appear and not be covered by the tool tip.

1 Like

You saved me hours of stupid work, thanks :grinning:

It never crossed by mind, it could be just a “display” problem".

I used Chrome, zoomed in, hit the remove button, and zoomed out again and confirmed. Perfect.

Now all my “locked” applications are “open for business”.

I can’t thank you enough, so I wont try…

Du you know if there is a FAQ for the changes in the Web IDE. There are many smaller bugs (new files are filled with code from other files, the back-button when looking at included libraries are gone,…). And with so now many forum threads to read regarding the library handling, it would be nice if Particle published known bugs, workarounds, planned fixing and so on.

1 Like

No FAQ for that I’m afraid, but you can always bombard Particle with issues on the GitHub repo.

@ScruffR

I am having the same issue, can you share the other libraries that are safer to use with the DS18 sensors?

I tried the new project route, didn’t work!

The following came from Particle regarding the community library: If I am using communities libraries then I should feel safe?

Particle libraries are reliable. In addition to building and sharing our own high quality libraries, Particle verifies and promotes high quality community libraries that are fully documented, perform reliably, and include a variety of usage examples. Using our official and verified libraries means you’ll spend less time debugging and more time building your project.