Fatal Error: Why do I still get this after all this time when following the instructions?


#1

I still get fatal error when adding libraries… I was hoping this would end at some point. Yes, I follow the instructions…

https://i.imgur.com/vptV8sS.jpg


#2

Because the library contributor hasn’t upated the library to the new library format, but your target firmware requires the new structure.
If you don’t explicitly need special features of that spark-dallas-temperature library you could use some alternative library (e.g. DS18B20)

See here


#3

Ah. Ok… Having been away a long time I might have missed these specific details and gotchas. thanks.


#4

Ah Hah! My problem of the day!

Thank You, Thank you.


#5

Now I remember why I stuffed my Photon in a drawer to be forgotten. What a complete bungle.


#6

@pwillard, what is your comment about?

If you are facing issues, let us know and the community volunteers along with Particle team can see how best to assist you.

Do appreciate if the community guidelines can be adhered to. Thanks!


#7

You’ve also missed several iterations of system firmware that have been released to improve the entire platform.
I personally don’t feel it’s fair to dismiss it as ‘a bungle’ because a community-contributed library hasn’t been updated to comply with the much improved system firmware.

The community is always glad to help should you encounter difficulties.


#8

Well, if I sounded frustrated… when I posted… I had just finished reading this on the webpage.
> Particle libraries are reliable. In addition to building and sharing our own high quality libraries, Particle verifies and promotes high quality community libraries that are fully documented, perform reliably, and include a variety of usage examples. Using our official and verified libraries means you’ll spend less time debugging and more time building your project.

So yeah… I was like… “I beg to differ.”

I think my Spark has a recent firmware as it says its running 0.60. I’m still not sure why the WEB IDE is making me feel clueless… but its succeeding in doing so.


#9

These parts of the statement need to be understood correctly.
The own libraries are marked with :particle: icon and verified ones with and the statement should hold true for libraries marked that way.
For all other libraries (without special tag) Particle has to rely on the contributors (or individuals who take ownership of libraries contributed by others) to have done their job right and keep the libraries up to date - but some contributors just don’t or can’t and not everybody is willing to take on libraries abandoned by their original contributor.
e.g. in the past I have taken on fostering care for some libraries - like DS18B20 - but I haven’t got the resources to take on more, especially not when there are working alternatives for out-dated/broken libs - and the same goes for the other Elites and Particle.


#10

Yup… got it. And… taking your original advice… I have had much better luck with the DS18B20 library.