Spark Core gone from Device listing, can't add it back

It’s been a month or two since I’ve logged into my build account, but I went in to try some new code and my device is no longer listed.It was there last time I logged in, I flashed new code to it…
I’ve tried to put it back using what I think is my device ID ( it didn’t work until the core was online, so I think that’s the right ID…) and it looks like it’s added, though the device is listed as an “Other” with a question mark.
However, when I try to flash code to the Core I still get a " Error: No devices associated with your account. " message. Logging out and logging back in removes the core from my device list and I have to start over.

My questions:
How do I find my Device ID? I no longer have the box/paperwork that came with the Core and can’t find the ID on the device itself.

Once I’m sure I have the right ID, how do I add it and get it to stay?

When you put your device into listening mode, you can retrieve the ID via any serial monitor (e.g. PuTTY) by entering i or via CLI particle identify

Thank you. After posting I continued to do some more searches and had also found that information. I had the right ID, but it’s still not adding it to my device list in any useful way.

Another member has got a similar issue and I’m sure it’s being looked into - stay tuned.

1 Like

Hi @Airmon,

It sounds like the device is already claimed? Can you email us at, or use the ‘request claim’ feature in the IDE?


It was previously claimed by me, with this account. I don’t get a message saying that it’s been previously claimed, the “Add Device” seems to work and the device gets added, but the type is listed as “?other”, it’s unusable for uploading code, and it’s removed if I log off the site.
I’ll email.

1 Like

I am getting the same issue. I’ve had the same device claimed and added in the IDE added for months, and today when I open the IDE there are no devices listed, even though the device has been claimed and is connected to the cloud successfully.

1 Like

Devices should be visible now. If they show up in Other Devices section, PM me you device ID.

1 Like

Thank you. Now it’s working!


Mine is back as well. What happened?

1 Like

We fixed the issue we had with listing devices :slight_smile:


Hi I have the same problem. My spark core appears as “other” device. I deleted the device, added it again using the Device ID with the same result.
The problem is that when I compile my code a previously correctly compiled code, now has errors in libraries.
Another issue I have is that I can’t claim it using the iphone app. The app doesn’t find anything when trying to claim the core.

Any help will be appreciated.