Spark Core can not be connected to the network

Hi Guys,

I just bought a Spark Core, but the core could not be connected to the network.

I used Android APK which download from the website but not from the Google play becuase it can not wok in China, When i tried to sign up to Spark Cloud by using a connected Android Phone, it mentioned : “Spark could not be reached at this time. Please check your internet connection, and try again later.” Also mentioned the similar when i tried by an existing account .

My wifi is WPA-PSK/WPA2-PSK .and my Spark core is in the Listening Mode. and Router is TP-LINK beside my Core, and DHCP is enabled. None of firewll in my Computer or Router. and my Core is chip antenna powed by USB (not be drived). I tried clear my memery of Core not problem still (Still not to try recovery to Factroy status…).

And my network will be home used network , which belong to China RailCom ISP.

oh, i also tried by TI’s Smart Config program both including Android APP or Java Applet App, but also cann’t connect to the network.


  1. Have you tried connecting using the Tinker app?
  2. Have you also tried connecting using the serial USB connection and a terminal program?
    If one method fails, try the other…

See also this page in the documentation.

Perhaps you already know - but just to be sure - your android phone needs to have Wifi “ON” and be on the same Wifi network as the core.

Try to assign your wifi settings to core directly from com. Search for instructions in troubleshoot page.

1: Not tried using USB, I wanna confirm it may work except using usb first.
2: Tinker App means Android APP?, as mentioned above , the Appp cannot login, so not tried.

Hi, @MisterNetwork

Core, Phone,Router , all is beside me .the Router has a wifi named ‘Chris’, and Phone already connected to the ‘Chris’.

What channel are you using for wifi? If it’s channel 12, 13, or 14, the Spark may not work with it right out of the box. @dave posted some sample code in this gist a while back, but I’m not 100% certain if it is still the recommended solution since a lot of wifi/network/connectivity work was updated in the firmware recently.

Maybe someone from Spark or Elite can confirm this?

(Ping: @Dave, @jgoggins, @zachary, @mdma, @bko, @peekay123)


Hi, All,

I resolved it , because my App network function has been blocked by android OS system (MIUI) .

But another problem come out , it mentioned me “No Cores found, TRY AGAIN” when i tried to connect wifi by using Spark Android App, and the LED of Core became into Flashing Green insdead of Flashing Blue, and it turn into breathing cyan when i restart the Core(power off, then power up)…

B.T.W, It has been connected successfully by using USB before i resolve the problem, because i want find out the really reason so i clear the wifi memory in the Core

1 Like

:slight_smile: Hi , all, it resolved when i clear the wifi memory again in Core.