Spark by hand + JTAG help

Hey guys so finally I’ve soldered my JTAG board to debug my newly built spark!

Of course things didnt go the way I expected so here I am.

I’ve soldered the Core v1 using a mixture of components from Bdub’s post and a proper 3.3nH inductor.
Here’s how it looks like:

Need some help debugging my core guys, can someone give me some pointers on what should be working by now? (I’ve just finished my core, so no bootloader and so)

Well, when trying to burn the bootloader I get errors like this:
(using STSW-LINK004 from ST Link website)

I’m soldering the board according to this brd file:

Please help me bringing this core to life!

Thanks in advance,


Maybeeee the STlinkV2 is able to provide enough power for the core? :smiley:

Maybe @BDub can share how he programmed his hand-made ones!

Hey that purple Core sure looks familiar!

The ST Link does not have enough juice to power the Core by itself. All you have to do is provide power via the micro USB connector on the Core in addition to having the ST Link connected to the JTAG Shield/Homemade awexome thing :wink:

Once you get it programmed and generate a key pair, ping us again so we can make sure the Cloud knows about your Core.

1 Like

Edit: Oh my god @Bdub you’re like the god of the spark. It worked!

I successfully burned the bootloader! Now what? Dont even know how to continue
I’m on Windows 7, how do I
dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D locker-firmware.bin and
dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D cc3000-patch-programmer.bin?

So I fixed the USB connector, now what? What is supposed to happen when I connect it through the usb?

Simply enter DFU mode and program the cloud public key and at the same time generate your own core keys.

You will need to install DFU-util to run those commands.

Spark cli will be a great tool moving forward :slight_smile:

How to enter dfu mode?
when i connect the spark to a pc it should start locating drivers?

I think reading the documentations is always a good start:

There’s also a guide here:

Thanks @kennethlimcp!

The thing is my spark doesnt blink at all when connecting it to USB.
I’ve already tried to put it in DFU mode using that post, it just wont blink.
So I just thought that maybe when building a new core you would have to install something other than that.

Okay so I have some debugging to do, thanks again!

Since you successfully got the bootloader loaded, why not use JTAG to also flash the tinker app? You can get the app on this page - - core-firmware.bin. Flash it to address 0x8005000

At least then you know the bootloader has got some code to run, and you’ll be able to hopefully see the core come to life! (Getting DFU mode working is tricky the first time - hold mode, then touch reset, still holding mode for 3-5 seconds.)

As well as flashing your core’s private key and the server public key, you’ll also probably want to flash tinker as the factory default app. The locations for these are given in the external memory map.

Hmm, so again my guess is that I’ve soldered wrong… At least it was not 100% wrong, since I’m able to flash things.

Anyhow, I was able to flash the bootloader, and the tinker ap @0x8005000 buuut!
Not being able to see stuff like blue flashing madness, I’m measuring voltages on the core.

Vin = 5v [RST pressed] || Vin = 4.9V [RST not pressed]
Rx, Tx, A7~A0 = 0V
RST = 3.27V [RST not pressed] || RST = 0V [RST pressed]
3v3 = 3.28V
d7 = 3.15V
d5 = 3.15V
d3 = 3.15V
Current drawn from Vin-GND (applying 5v pair) is 30mA
When pressing RST it is next to 0.5mA.

Any assumptions? Ideas? Doesnt this RST seems weird? Help!

@gcats if your RGB led is not lighting up at all, perhaps it’s on backwards or something? Dig into the specs and wiring there… I had issues with mine, and had to alter the code to generate the correct colors (after I had rotated the LED correctly)

You’re like the god of the spark!
Okay so I short circuited a led between two terminals that should be blinking the blue and … Vouila!

So I need to resolder stuff now, but since I dont have the necessary equipment now, I’ll just wait. Keep you posted guys, you’re all awesome!

Edit: seems like I have the same issue as @jwalker, as in here.
How did you get to connect to the cloud @BDub?
Doesnt look very promising though…

1 Like

Okay so here’s what I’ve got
I rotated the led 180degrees and now it is blinking cyan each 500ms (my guess)
When I try to enter DFU mode it blinks cyan, or, if i press MODE for long enough it blinks pinkish.
Sad thing is that in either mode no USB is detected on the Windows 7 side… Any suggestions?
Can’t seem to be able to tinker as well… Maybe because I don’t have private and public keys?

here you can see the flashing frequency
after installing modified bootloader from BDub
possibly soldered LED in wrong terminals

Well, the frequency remains the same if I get to burn newest bootloader.